summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-03 10:17:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-03 10:18:21 +0200
commit38f7187d8cd6e34a5e4b5755e08aa77c5ee13db0 (patch)
treee94ff360c20def2225ffeb06b4bacf271b45062f /dev-python/apsw
parentx11-misc/zim: switch to optfeature dev-vcs/breezy (diff)
downloadgentoo-38f7187d8cd6e34a5e4b5755e08aa77c5ee13db0.tar.gz
gentoo-38f7187d8cd6e34a5e4b5755e08aa77c5ee13db0.tar.bz2
gentoo-38f7187d8cd6e34a5e4b5755e08aa77c5ee13db0.zip
dev-python/apsw: Bump to 3.45.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.45.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 121ddacd4009..3400d17ff13a 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.45.1.0.gh.tar.gz 904083 BLAKE2B 4cf397557bfe36e38fd48d124345de395b77a8dd313ebd77f97624d873123d5ecd82e56b6e134849e00a77f94b0c3ee2fa0cfc888b8fbbddc34b99b3274b8dc8 SHA512 5d754c45881db9e299c70bd0c290211f7e30421da258b25b5aa0d8b3c97a10622f0b75735fc84d687f78403fc257139ffc249d926be611a4101b98caf3c60a3a
+DIST apsw-3.45.2.0.gh.tar.gz 904263 BLAKE2B 4071e2dc24a304f4f08cefc87cce27d617cab8f2699d134134b2c0c2618422139ebdd38dfafcb17e8a6c515fe5e799d6d827ef5099af23cf628f26c18764aa0a SHA512 864cde25cfd15e3cbddbf1df80dbd861e93c2e8ea458a9f16d0ff4a8ecaf17721321f08bf7ab0659c0a18845be5bcc879b6708175ed971b263a0f274c08b05b9
diff --git a/dev-python/apsw/apsw-3.45.2.0.ebuild b/dev-python/apsw/apsw-3.45.2.0.ebuild
new file mode 100644
index 000000000000..7fe76f0deaa5
--- /dev/null
+++ b/dev-python/apsw/apsw-3.45.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}