summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-26 07:11:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-26 08:03:36 +0200
commit37eaa4ea38c98af043ddf064b652c2e8eaf44acb (patch)
tree035330e617ac3dcd2c60b825b007bb0cb8ffc7f6 /dev-python/apsw
parentdev-util/stripe-mock: Bump to 0.167.0 (diff)
downloadgentoo-37eaa4ea38c98af043ddf064b652c2e8eaf44acb.tar.gz
gentoo-37eaa4ea38c98af043ddf064b652c2e8eaf44acb.tar.bz2
gentoo-37eaa4ea38c98af043ddf064b652c2e8eaf44acb.zip
dev-python/apsw: Bump to 3.42.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.42.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index b3f946b489e6..6b332db37543 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.42.0.0.gh.tar.gz 863081 BLAKE2B 5eee11867e41c396be7cc9bbde1c4bb82a1e294ddd05613d6fbd50ac95c2d5e374632fde3215a838779253ad0f2eb97a4550771767a9f9f7a53c062c7eee5f7e SHA512 e0afa56d1a1d4e8627fe721c36098182efad23128cb053c7c25fc6412d6fe63a50beb66e0bc8dce527c17ff7bd9adb9e71a35fbc4ee769b5231d4dd941b21572
+DIST apsw-3.42.0.1.gh.tar.gz 881270 BLAKE2B a983aebe53f6baf419fb0fec6d87797d11c1e1f0fadd546139c9b9c3cec6f8848e79af46a928597e6cf33937bb2b2e2157cf908cf18152c7f956864e3d09fe2c SHA512 78a02c8e987df90838923b2a2d4838a184e7e8d9be70a09a4a27eb43e9f06546f831895ab519b681f628e5432b3e5b71d56ecc2f3e45a89765dc13667ca6e844
diff --git a/dev-python/apsw/apsw-3.42.0.1.ebuild b/dev-python/apsw/apsw-3.42.0.1.ebuild
new file mode 100644
index 000000000000..cbe98664d4c3
--- /dev/null
+++ b/dev-python/apsw/apsw-3.42.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}