summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-31 04:56:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-03-31 04:59:06 +0200
commite5a2961964569c6934261bb3dd218c529fa743fe (patch)
tree40a0925de975ce952ac6356a49c10cc0b3373386 /dev-python/apprise
parentdev-python/recurring-ical-events: Bump to 2.2.0 (diff)
downloadgentoo-e5a2961964569c6934261bb3dd218c529fa743fe.tar.gz
gentoo-e5a2961964569c6934261bb3dd218c529fa743fe.tar.bz2
gentoo-e5a2961964569c6934261bb3dd218c529fa743fe.zip
dev-python/apprise: Bump to 1.7.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.7.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index fae8247d7bc3..9c6b2d8567f7 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1 +1,2 @@
DIST apprise-1.7.4.tar.gz 1648673 BLAKE2B 33c91a63e3d0e730dcfe2b99433cd97e16ff9635e9ff717e9c4f7b708e6536185265e591ff419a785044877cadd4793f2df73fe9420ffed65838fb16654810f8 SHA512 5e3ab2136f1bdbd9d769fb3e3c5a5c899834b7ffb6ba57f3601079d516e31bed9d988b76745c251fff6df91f1fcd186d23a0878165ad73b811f76a8118278a64
+DIST apprise-1.7.5.tar.gz 1652098 BLAKE2B 01acc8be50b76cdcb5c7ce068b6f644d5edbbf28ea964d95e8d2ea0579a3a9c60e9715ae482ec0d7f16f4ce8118acf99e4159249bc763f268f89362a3e4fcde9 SHA512 d783d74a8e4a9f9b39c2ab86c0207a99e6f5fe30492b5bc50cb7008477acc1c5831d94c18bd3cee22fa28e028571108237191cc7a253aa072e121cecd0ce7afa
diff --git a/dev-python/apprise/apprise-1.7.5.ebuild b/dev-python/apprise/apprise-1.7.5.ebuild
new file mode 100644
index 000000000000..a85837c32c40
--- /dev/null
+++ b/dev-python/apprise/apprise-1.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest