summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 06:14:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 06:14:32 +0200
commit914f18a309185dfeb450678d80b4972a93c80eee (patch)
treeefa97708c140e13dafb8c3a5ca5d16bf1af6923c /dev-python/apispec
parentdev-python/identify: Bump to 2.2.6 (diff)
downloadgentoo-914f18a309185dfeb450678d80b4972a93c80eee.tar.gz
gentoo-914f18a309185dfeb450678d80b4972a93c80eee.tar.bz2
gentoo-914f18a309185dfeb450678d80b4972a93c80eee.zip
dev-python/apispec: Bump to 4.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-4.4.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 2f3744effeb2..77363d037bc5 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-4.4.1.tar.gz 64424 BLAKE2B b46390659334f5ce5aa83fd15207f5d1ad6d0e9c530f9e7d2b1a0f6a787498aad065153cde9237ce1ab408256e5cd698bbc674dc0316eb4ed16b874ce34611c4 SHA512 fea0787598ca93711eaa231675f97623eb3d6eb224e11c40e66857b95f48724618bf7a9bfda476b56c1c96fe70bb61675966b1f3fb073fe3f7e4da91e78d3d90
+DIST apispec-4.4.2.tar.gz 64660 BLAKE2B 1e53d4b3f8856e76565690773085dfcbaaab4e1771186eb8ea35f469d7c65b8d5bd6319af0ee32539de96ce5ff1889a15d74ac764d7bb9d0b415648af87d28db SHA512 8f8070ec1a084e5c5dda02d30103ff25a2fe096839aa2b1a75858297377e312e29a2d1cf4d373a53b7bffcbe9108489c2a2516e0e053c2de12ef90044b6b7e17
diff --git a/dev-python/apispec/apispec-4.4.2.ebuild b/dev-python/apispec/apispec-4.4.2.ebuild
new file mode 100644
index 000000000000..411599826ebf
--- /dev/null
+++ b/dev-python/apispec/apispec-4.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local deselect=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}