summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-19 00:47:35 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-19 00:47:41 +0100
commitf166bc8a1b4aca554bdeeadf813d84928b380a20 (patch)
tree399de65aa44d2e3e3db7d76b2264f247b6085a04 /dev-python/alembic
parentdev-python/cliff: Bump to 3.6.0 (diff)
downloadgentoo-f166bc8a1b4aca554bdeeadf813d84928b380a20.tar.gz
gentoo-f166bc8a1b4aca554bdeeadf813d84928b380a20.tar.bz2
gentoo-f166bc8a1b4aca554bdeeadf813d84928b380a20.zip
dev-python/alembic: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 294e1f23ee9c..df91474bd950 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.4.3.tar.gz 1108131 BLAKE2B d9c8b6d6aebce7a45194dd6c654f4a2627714a5c1f7cb7a1cf80ed8c3fe861e3bb7857811128787ddd6c093b4370784b40cddb385cfbd30f6134d537fe949d2d SHA512 925d8957fd9008d041737a9e79ec8d7a4c5deba1976e980362d355a75348c1638d783d9d48234a5bc3b2dc3f2f09dcb281d0c80ae0f0c5bc32e176c3dfa05463
+DIST alembic-1.5.0.tar.gz 1128073 BLAKE2B 067ebe7a8ee9b14fc782e0f5268990b07a8ae91ab8ae89daee119bb64f30b8cb966ff22ce71c67e476fafce7ae418952f253645b0f5b5b8a1abbf7f562794138 SHA512 a667e5b176770061c27ea7fdaafdbcdad64d968e22e729083fadd8e002530cc43909a955c3ccaa04329c393ab3f27ec5b944b03ba0ae5d29609b940e7cfb8ad5
diff --git a/dev-python/alembic/alembic-1.5.0.ebuild b/dev-python/alembic/alembic-1.5.0.ebuild
new file mode 100644
index 000000000000..9600e4d2d12c
--- /dev/null
+++ b/dev-python/alembic/alembic-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}