summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-18 15:49:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-18 17:45:39 +0200
commitc3606196677e830726b722dce39edf0f365dda4c (patch)
tree2789b801eb75d75f46749689dea929132d2669e9 /dev-python/aiosignal
parentdev-python/autobahn: Fix asyncio testing (diff)
downloadgentoo-c3606196677e830726b722dce39edf0f365dda4c.tar.gz
gentoo-c3606196677e830726b722dce39edf0f365dda4c.tar.bz2
gentoo-c3606196677e830726b722dce39edf0f365dda4c.zip
dev-python/aiosignal: Add missing dev-python/pytest-asyncio dep
Closes: https://bugs.gentoo.org/930183 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosignal')
-rw-r--r--dev-python/aiosignal/aiosignal-1.3.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/aiosignal/aiosignal-1.3.1.ebuild b/dev-python/aiosignal/aiosignal-1.3.1.ebuild
index 3166f7d518dd..f580fbd017b2 100644
--- a/dev-python/aiosignal/aiosignal-1.3.1.ebuild
+++ b/dev-python/aiosignal/aiosignal-1.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,9 +25,15 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc
RDEPEND="
>=dev-python/frozenlist-1.1.0[${PYTHON_USEDEP}]
"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
python_test() {
- epytest -o addopts=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
}