summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-26 13:21:10 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-26 13:22:08 -0700
commit38ad0af4165fc2ff98c65a1fa42319124ada4a0b (patch)
treea29f7bf47c6369f4c8abc9ac87b880e1e70757ab /dev-python/aiohttp
parentdev-python/async_timeout: version bump to 1.2.1 (diff)
downloadgentoo-38ad0af4165fc2ff98c65a1fa42319124ada4a0b.tar.gz
gentoo-38ad0af4165fc2ff98c65a1fa42319124ada4a0b.tar.bz2
gentoo-38ad0af4165fc2ff98c65a1fa42319124ada4a0b.zip
dev-python/aiohttp: version bump to 2.1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-2.1.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 10ce032d4c96..03ca694e5d19 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -8,3 +8,4 @@ DIST aiohttp-1.1.5.tar.gz 577346 SHA256 8f4c31a10b0a96667ac8a13e3756a3505e040c42
DIST aiohttp-1.2.0.tar.gz 589818 SHA256 b2fa11df067207ff15813be84b78910f6f9d897f02e9c345993b9962802a6bea SHA512 4101f0aad0d6bb8caf931dbd7f9e07bfdaa445796af92c84ea999538c2767f3cd62740ea9c7e07f255eb57b52e967e5343461809a5d5f4e8b12cd4383753bd77 WHIRLPOOL 239f802ce1dde24b3e1c6fba39357822564256f1aae167b44164d9bab3e67113400534df0835ca6b5245b8229dcab752149774c7adde1e1aef2a0f549d2d33ad
DIST aiohttp-1.3.3.tar.gz 526273 SHA256 103433f594442b98ed4af9db02331e548a0ef2d4cfd02207ea24ed9eb85862e4 SHA512 39342270f615f7e5e01889ad50ccb60335151e94631007b105acda9930038d2fb66128469ca44043280c9f737130e2361129e2fa1c857a7654a1151b98a19a69 WHIRLPOOL c6689d990f31ce45e012ca26a459993505d264fdb36f87481588eb747e5cd5c5aa38dd2e08c10f2d9b7bfd16622a7b312e08c7fb7c33929e0bdf872fac2e92bf
DIST aiohttp-2.0.7.tar.gz 739606 SHA256 76bfd47ee7fbda115cff486c3944fcb237ecbf6195bf2943fae74052fb40c4fe SHA512 b16564f254ced6356fc4a49894fd85ba230b0382f2b83a12930f8c434e9175954248d8501c1a3a84ac1135a680581f36705ebd602db1589192ba073cf837edf2 WHIRLPOOL 5628bc729900b047b722227b1de688b16eea08f5d14e987e3348888113854f8cca9f5e6ae943105227dfec455dadd6cfa86fed8013b4ef4bf382f306a4bb8907
+DIST aiohttp-2.1.0.tar.gz 748642 SHA256 3e80d944e9295b1360e422d89746b99e23a99118420f826f990a632d284e21df SHA512 bd8eea366d380b88ba2c88d2aab722cd0970d2239dd0057cf4596f472a1b1bf38aebbd6cc707379ad9b5f901f93a56c1c4dd32584cb2636af0e013aa11388e25 WHIRLPOOL 45cf17ea7db2eb385d922cd4cdf5aac40244939066a6632f453fa2545fe1a73dfe0d0c43c3dcd60936a403174a69a8fd027dae2e55fc901594d388bd4b5c4cc3
diff --git a/dev-python/aiohttp/aiohttp-2.1.0.ebuild b/dev-python/aiohttp/aiohttp-2.1.0.ebuild
new file mode 100644
index 000000000000..c19a47198dac
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-2.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/yarl-0.10[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}