summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/SaltTesting
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/SaltTesting')
-rw-r--r--dev-python/SaltTesting/Manifest3
-rw-r--r--dev-python/SaltTesting/SaltTesting-2014.8.5.ebuild26
-rw-r--r--dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild29
-rw-r--r--dev-python/SaltTesting/SaltTesting-2015.5.8.ebuild31
-rw-r--r--dev-python/SaltTesting/files/SaltTesting-0.5.2-silence-DepricationWarning.patch17
-rw-r--r--dev-python/SaltTesting/metadata.xml12
6 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/Manifest b/dev-python/SaltTesting/Manifest
new file mode 100644
index 000000000000..d873528b40a2
--- /dev/null
+++ b/dev-python/SaltTesting/Manifest
@@ -0,0 +1,3 @@
+DIST SaltTesting-2014.8.5.tar.gz 32787 SHA256 ee1681e13f09646ce08f9e95e700eddb7d882f6a87051f2caee0e844aca69339 SHA512 f3a25d36c94e01d448c3a3ce1bbf831ab9d806847ccc44a4e3d2cc40ac8f967f570d6724fef3b61838e14f8624a092e83e9db46101509c22e817836b545c9f58 WHIRLPOOL bed7114ea75b496bf87efccb937e75d744b2f416a74f4df979ce151037cab13485b863d1ab757ff59810517df9c1a297b1f0e891e63ad64d7436081ddc5d281b
+DIST SaltTesting-2015.2.16.tar.gz 77908 SHA256 05ddb56d9775c404b2c8536bd5f8fce97cf35777b1077eed895175ae8db02d1d SHA512 170ff267be0edd24da1e90d70795fb2ff5193407e766a4d90cef550130b997ce4f4ecc0d327ca8555fbe14fd3587620b8e356e1060a91edac62cf114356ada48 WHIRLPOOL 736babf2df8922ce092fd0578fc2c45b3a9773975d63dbd12d04bb428e020ad4f8f798f9876fceb922154e5d8e55f105524a70b4514a582e84064f5fc332887a
+DIST SaltTesting-2015.5.8.tar.gz 79236 SHA256 c4256f1e22bf90951fdee46444ec8c9f040f5a75b405151f4b8cd9a30091a559 SHA512 8f517c13428d679d44c288cccd02033f79cbbe93c0c1adad48179d41d97cb7c4f2b49d43a10fa52e803f1fddf9b05595b8a9f894612777388ee5c15a3919ecbf WHIRLPOOL 9b8f2f9dc7043d16f3479d15f1c668899a2991c7af789f5b1c02ca4a5749aad8dd50183da9567f78412d0d2f32170c5c63341fd440a5c14b4e38664b3f433776
diff --git a/dev-python/SaltTesting/SaltTesting-2014.8.5.ebuild b/dev-python/SaltTesting/SaltTesting-2014.8.5.ebuild
new file mode 100644
index 000000000000..6f4a8cdcbda6
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2014.8.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7)
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
diff --git a/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild b/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild
new file mode 100644
index 000000000000..4664b1c5c316
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7)
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-python/requests-2.4.2"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/SaltTesting/SaltTesting-2015.5.8.ebuild b/dev-python/SaltTesting/SaltTesting-2015.5.8.ebuild
new file mode 100644
index 000000000000..43517199653a
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2015.5.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ >=dev-python/requests-2.4.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+# The testsuite requires the package salt itself which has never been added to portage
diff --git a/dev-python/SaltTesting/files/SaltTesting-0.5.2-silence-DepricationWarning.patch b/dev-python/SaltTesting/files/SaltTesting-0.5.2-silence-DepricationWarning.patch
new file mode 100644
index 000000000000..292a74c5c648
--- /dev/null
+++ b/dev-python/SaltTesting/files/SaltTesting-0.5.2-silence-DepricationWarning.patch
@@ -0,0 +1,17 @@
+--- a/salttesting/unit.py 2013-10-24 10:57:42.000000000 +0000
++++ b/salttesting/unit.py 2013-11-12 18:47:11.245838201 +0000
+@@ -42,10 +42,10 @@
+ class TestCase(_TestCase):
+
+ def assertEquals(self, *args, **kwargs):
+- raise DeprecationWarning(
+- 'The {0}() function is deprecated. Please start using {1}() '
+- 'instead.'.format('assertEquals', 'assertEqual')
+- )
++ #raise DeprecationWarning(
++ # 'The {0}() function is deprecated. Please start using {1}() '
++ # 'instead.'.format('assertEquals', 'assertEqual')
++ #)
+ return _TestCase.assertEquals(self, *args, **kwargs)
+
+ def failUnlessEqual(self, *args, **kwargs):
diff --git a/dev-python/SaltTesting/metadata.xml b/dev-python/SaltTesting/metadata.xml
new file mode 100644
index 000000000000..9e2d309a1252
--- /dev/null
+++ b/dev-python/SaltTesting/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">SaltTesting</remote-id>
+ </upstream>
+</pkgmetadata>