summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 18:08:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 18:33:35 +0200
commitd0d8b0b1036bbb5fcd6ef7a375adbd8f087bc0d0 (patch)
tree6582d12849f9b7d73aa89fe2d4a5bc24d6404347 /dev-python/Babel/Babel-2.8.0-r1.ebuild
parentdev-python/alabaster: Port to py39 (diff)
downloadgentoo-d0d8b0b1036bbb5fcd6ef7a375adbd8f087bc0d0.tar.gz
gentoo-d0d8b0b1036bbb5fcd6ef7a375adbd8f087bc0d0.tar.bz2
gentoo-d0d8b0b1036bbb5fcd6ef7a375adbd8f087bc0d0.zip
dev-python/Babel: Port to py39, fix tests
Closes: https://bugs.gentoo.org/714854 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Babel/Babel-2.8.0-r1.ebuild')
-rw-r--r--dev-python/Babel/Babel-2.8.0-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/Babel/Babel-2.8.0-r1.ebuild b/dev-python/Babel/Babel-2.8.0-r1.ebuild
index f970db31cb9f..8dc11d6ec291 100644
--- a/dev-python/Babel/Babel-2.8.0-r1.ebuild
+++ b/dev-python/Babel/Babel-2.8.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6..9}} )
PYTHON_REQ_USE="threads(+)"
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -24,3 +24,12 @@ DEPEND="${DEPEND}
distutils_enable_sphinx docs
distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
+src_test() {
+ local -x TZ=UTC
+ distutils-r1_src_test
+}