summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-10 13:37:12 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-10 13:37:12 -0400
commiteefd23c676557513081e9c9dbb97fc4e93e2cff1 (patch)
tree104071d69f4822879fe06f86756619e85d3274fc /dev-php
parentkde-plasma/kde-cli-tools: KDE_HANDBOOK=forceoptional, KDE_TEST=optional (diff)
downloadgentoo-eefd23c676557513081e9c9dbb97fc4e93e2cff1.tar.gz
gentoo-eefd23c676557513081e9c9dbb97fc4e93e2cff1.tar.bz2
gentoo-eefd23c676557513081e9c9dbb97fc4e93e2cff1.zip
dev-php/PEAR-Auth: New snapshot version from github
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Auth/Manifest1
-rw-r--r--dev-php/PEAR-Auth/PEAR-Auth-1.6.5_pre20150209.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-Auth/Manifest b/dev-php/PEAR-Auth/Manifest
index 7c0fa5a8a4ab..3354188687f2 100644
--- a/dev-php/PEAR-Auth/Manifest
+++ b/dev-php/PEAR-Auth/Manifest
@@ -1 +1,2 @@
DIST Auth-1.6.4.tgz 56048 SHA256 5fb31a2f758474fd9a044afbc387d65fef38732b8f313837971b9a16104779e6 SHA512 670f77d0b68d4701ddb19093637ac341d75411bdacc527fc2fb1cf412d87cf9c78595f925a518e3b5b577635f59904c3c1f499cc8a357ee0c807652070e2961b WHIRLPOOL 22e01a2c7556eb409a0caee0320bfd8269e8f606d67286df658db1f63266faac385e732f63ede13386be22001bc293a1abcaa29fb20a26f85eec6c760f6db7fc
+DIST Auth-1.6.5_pre20150209.tar.gz 62733 SHA256 b1165facc7f133acbfe41e8def74acd0e864ff39de6d92f90b97f075ace86124 SHA512 4d3ebe3eaa8129ce205adcc3c2b8aadbf2f3a3624a597f901944b61bccc052c92b922e6762b9e061fdffd885c5b20e32b6dd1453e205f734f6eed0b40d0a8338 WHIRLPOOL a04b96d4a8e9c4a91fa85482eaa29542ed6d47daf7f1bb9273faa346e2868473ca18819f27019a23a76e0a747c45d7bbc502f7229a69b8073262edbbc8a795a2
diff --git a/dev-php/PEAR-Auth/PEAR-Auth-1.6.5_pre20150209.ebuild b/dev-php/PEAR-Auth/PEAR-Auth-1.6.5_pre20150209.ebuild
new file mode 100644
index 000000000000..2ad9eb1050b4
--- /dev/null
+++ b/dev-php/PEAR-Auth/PEAR-Auth-1.6.5_pre20150209.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit php-pear-r2 vcs-snapshot
+
+SRC_URI="https://github.com/pear/Auth/archive/9c6817a6ae4bfabf9d6ffa91cbcdca6ab2e31ce7.tar.gz -> ${PEAR_P}.tar.gz"
+DESCRIPTION="Provides methods for creating an authentication system using PHP"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal"
+RDEPEND="!minimal? ( >=dev-php/PEAR-Log-1.9.10
+ >=dev-php/PEAR-File_Passwd-1.1.0
+ >=dev-php/PEAR-Net_POP3-1.3.0
+ >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-MDB
+ >=dev-php/PEAR-MDB2-2.0.0_rc1
+ >=dev-php/PEAR-Crypt_CHAP-1.0.0
+ >=dev-php/PEAR-SOAP-0.9.0
+ >=dev-php/PEAR-File_SMBPasswd-1.0.0
+ >=dev-php/PEAR-HTTP_Client-1.1.0 )"
+
+pkg_postinst() {
+ if ! use minimal ; then
+ elog "${PN} can optionally use php's imap and soap features."
+ elog "If you want those, recompile dev-lang/php with these flags in USE."
+ fi
+}