summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-07-12 15:48:49 -0400
committerBrian Evans <grknight@gentoo.org>2016-07-12 15:48:49 -0400
commitde03399ccc489991bde7e8fa975d9d94f2e6befa (patch)
treec01a6e4e3909bd600720eeba468760e23a998f39 /dev-php
parentdev-lang/ispc: version bump (diff)
downloadgentoo-de03399ccc489991bde7e8fa975d9d94f2e6befa.tar.gz
gentoo-de03399ccc489991bde7e8fa975d9d94f2e6befa.tar.bz2
gentoo-de03399ccc489991bde7e8fa975d9d94f2e6befa.zip
dev-php/pecl-mysqlnd_ms: Version bump; Drop php 5.4 USE
Bump to a VCS snapshot that can build on PHP 5.6 There are many intermediate changes which prevent a direct patch on 1.5.2 for PHP 5.6 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-mysqlnd_ms/Manifest1
-rw-r--r--dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild5
-rw-r--r--dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild37
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-php/pecl-mysqlnd_ms/Manifest b/dev-php/pecl-mysqlnd_ms/Manifest
index 63f3cd44d205..b6618b3b2808 100644
--- a/dev-php/pecl-mysqlnd_ms/Manifest
+++ b/dev-php/pecl-mysqlnd_ms/Manifest
@@ -1 +1,2 @@
DIST mysqlnd_ms-1.5.2.tgz 385916 SHA256 22b9ba1afb36b3df11c1051c813bc07889c815d1d9993bb07ffda182665b472f SHA512 5ab888d683384e9d2b33df8d057cf438411b6506759a80b8bad79608bb4029abf77535ffc8472e8e478d5d456c2260b5dd4bc68396180a9ebfed45f90bdc8d7d WHIRLPOOL 6d3d8786c74d4dfac384af3ea9f0cd8664e99aeaa766806ef8319c955135ab57092c2db27ef615def5574ab05c5a8a4e8e1f7bff9888a4cd3b3fc660c623fbe0
+DIST pecl-mysqlnd_ms-1.6.0_pre20141127.tar.xz 320604 SHA256 2cb2df946f020bcfcec1ff40b6a273dbfe69955fabe348a4804fba6897d55382 SHA512 44ca22d41d1064fb7ad3545978facd73f4279611769ee450016e8325013129b4414c637f3cb621078d4cd8e46a3ea5b9f4f16a580f9ecf389c637606a8c50ec5 WHIRLPOOL 640586e0cfbbf584cb18b4e38fbee9a90e0b929120428ea319e66276216f341a1ded65f08306be43028c8c13e3131e1f3fc98987386ccd03be39210616af5560
diff --git a/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild
index 28ab4838571c..9ac4bd2d93e3 100644
--- a/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild
+++ b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -9,7 +9,7 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
# php5-6 fails to build
-USE_PHP="php5-5 php5-4"
+USE_PHP="php5-5"
inherit php-ext-pecl-r2
@@ -22,7 +22,6 @@ IUSE=""
# Specifying targets due to USE flag transition
DEPEND="
- php_targets_php5-4? ( dev-lang/php:5.4[mysqlnd] )
php_targets_php5-5? ( || (
dev-lang/php:5.5[-libmysqlclient,mysql]
dev-lang/php:5.5[-libmysqlclient,mysqli]
diff --git a/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild
new file mode 100644
index 000000000000..1ac948d8fdf1
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="mysqlnd_ms"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-5 php5-6"
+# This is an SVN snapshot stored locally
+SRC_URI="https://dev.gentoo.org/~grknight/distfiles/${P}.tar.xz"
+inherit php-ext-source-r3
+
+HOMEPAGE="http://pecl.php.net/package/mysqlnd_ms"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A replication and load balancing plugin for the mysqlnd library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+# Specifying targets due to USE flag transition
+DEPEND="
+ php_targets_php5-5? ( || (
+ dev-lang/php:5.5[-libmysqlclient,mysql]
+ dev-lang/php:5.5[-libmysqlclient,mysqli]
+ )
+ )
+ php_targets_php5-6? ( || (
+ dev-lang/php:5.6[-libmysqlclient,mysql]
+ dev-lang/php:5.6[-libmysqlclient,mysqli]
+ )
+ )
+"
+RDEPEND="${DEPEND}"