summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-11-13 07:46:14 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-11-13 07:46:14 -0500
commitd3694e8be857d030fe3a30276a2835ce308979ed (patch)
tree37213e2bb3da00bd8d3b947bec9491fde50d162a /dev-php
parentapp-emulation/vkd3d-proton: Stabilize 2.13 x86, #943353 (diff)
downloadgentoo-d3694e8be857d030fe3a30276a2835ce308979ed.tar.gz
gentoo-d3694e8be857d030fe3a30276a2835ce308979ed.tar.bz2
gentoo-d3694e8be857d030fe3a30276a2835ce308979ed.zip
dev-php/pecl-apcu: drop 5.1.21, 5.1.22
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu/Manifest2
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.21.ebuild54
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild52
3 files changed, 0 insertions, 108 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index 1f341f75ed2f..2858a85947f5 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -1,3 +1 @@
-DIST apcu-5.1.21.tgz 92516 BLAKE2B 32d73b89bde9ef4eb01c9ad766930e87300b86776c95929607a8aaefba5043e3a7947d064416ac083ff38876fdb41bb03dab1552ac000082e54f809269b4c925 SHA512 a6ffe8349760d27cde0d86017a59a68e9639bf385e606622d807094f4e5fb305bb25b9ce00077d0856f4d223d44329f7a6314c229b62c78d8e2b085593c92bb3
-DIST apcu-5.1.22.tgz 93926 BLAKE2B abc3b27c4224da14b6438df9243f6b7b8245102f7eee0208daf1317bead5463d8f454e33536b8c949a2825140487faf9bb79745180a26e1f0015494e0986acb9 SHA512 8f2f4292679bc359ea680ecaf397d69de32bf67d57d719a4839a026ab1b96d5ec4725e92c5c0d1972a117a7cd3d3c456a1f4ec03192fda4657e685de60b9e93e
DIST apcu-5.1.23.tgz 90897 BLAKE2B 634366b99c993298c8720840d06ff3aed30bfb3f09fd7b63f4736766f4ac1b983f24317f161bf7dd1b3ab79053c905cc9136e8141468174177d2a05b94719590 SHA512 89e9f10f5d8d1a9503132e80140680be2a10d96f957f69b2f77cc1c496d15cc26dfe4c0368ebe46c72c68d1b4a794d3ddc95942b02d3ba5e8c971b09969058d8
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.21.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.21.ebuild
deleted file mode 100644
index 81f933acaf14..000000000000
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.21.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="apcu"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( NOTICE README.md TECHNOTES.txt )
-
-USE_PHP="php8-1"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="amd64 ~arm arm64 x86"
-
-DESCRIPTION="Stripped down version of APC supporting only user cache"
-LICENSE="PHP-3.01"
-SLOT="7"
-
-LOCKS="pthreadmutex pthreadrw spinlock semaphore"
-
-LUSE=""
-for l in ${LOCKS}; do
- LUSE+="lock-${l} "
-done
-
-IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
-
-REQUIRED_USE="^^ ( $LUSE )"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-apcu
- $(use_enable mmap apcu-mmap)
- $(use_enable lock-spinlock apcu-spinlocks)
- )
- # Broken upstream autoconf test disables if present at all
- use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- insinto /usr/share/php7/apcu
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of pecl-apcu was"
- elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
-}
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild
deleted file mode 100644
index bb44b8a9fa82..000000000000
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PHP_EXT_INI="yes"
-PHP_EXT_NAME="apcu"
-PHP_EXT_ZENDEXT="no"
-USE_PHP="php8-1 php8-2"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="Stripped down version of APC supporting only user cache"
-
-LICENSE="PHP-3.01"
-SLOT="7"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-
-LOCKS="pthreadmutex pthreadrw spinlock semaphore"
-LUSE=""
-for l in ${LOCKS}; do
- LUSE+="lock-${l} "
-done
-IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
-REQUIRED_USE="^^ ( $LUSE )"
-
-DOCS=( NOTICE README.md TECHNOTES.txt )
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-apcu
- $(use_enable mmap apcu-mmap)
- $(use_enable lock-spinlock apcu-spinlocks)
- )
-
- # Broken upstream autoconf test disables if present at all
- use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- insinto /usr/share/php7/apcu
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of pecl-apcu"
- elog "was installed to ${EPREFIX}/usr/share/php7/apcu/."
-}