summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-26 20:10:39 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-26 20:25:12 +0300
commit34015c0d4901ddeb7c8fb305d477b9b08dcdb3df (patch)
tree5bd914b6069f229d682ad1722bce87036f084c65 /dev-php
parentdev-php/phpcov: treeclean (diff)
downloadgentoo-34015c0d4901ddeb7c8fb305d477b9b08dcdb3df.tar.gz
gentoo-34015c0d4901ddeb7c8fb305d477b9b08dcdb3df.tar.bz2
gentoo-34015c0d4901ddeb7c8fb305d477b9b08dcdb3df.zip
dev-php/phpdepend: treeclean
Closes: https://bugs.gentoo.org/934666 (pkgremoved) Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpdepend/Manifest1
-rw-r--r--dev-php/phpdepend/files/autoload.php19
-rw-r--r--dev-php/phpdepend/metadata.xml11
-rw-r--r--dev-php/phpdepend/phpdepend-2.5.0-r1.ebuild46
4 files changed, 0 insertions, 77 deletions
diff --git a/dev-php/phpdepend/Manifest b/dev-php/phpdepend/Manifest
deleted file mode 100644
index 98beec1ba268..000000000000
--- a/dev-php/phpdepend/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST phpdepend-2.5.0.tar.gz 190823 BLAKE2B 9711a6bd113e912b651a577e1b00f388262843796219cdd26e012f1beccfd54aca62f4998a47d69c5ff3cc8705551fdd86bc538fdaf7173f5f25bc41f509c3e1 SHA512 927ff961773c3b2076b11b374035482c05b2da3a9777418c6fe0a491bd20eec431bfd75cd706674e231c9f73d97b6b0236eea12794cfff2d8ad52a6a6170e137
diff --git a/dev-php/phpdepend/files/autoload.php b/dev-php/phpdepend/files/autoload.php
deleted file mode 100644
index ce186c4f3d86..000000000000
--- a/dev-php/phpdepend/files/autoload.php
+++ /dev/null
@@ -1,19 +0,0 @@
-<?php
-$vendor_dir = '/usr/share/php';
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once("${vendor_dir}/Fedora/Autoloader/autoload.php");
-}
-
-\Fedora\Autoloader\Autoload::addPsr4(
- 'PDepend\\',
- __DIR__ . '/../src/main/php/PDepend'
-);
-
-
-\Fedora\Autoloader\Dependencies::required(
- array(
- "${vendor_dir}/Symfony/Component/Config/autoload.php",
- "${vendor_dir}/Symfony/Component/DependencyInjection/autoload.php",
- "${vendor_dir}/Symfony/Component/Filesystem/autoload.php"
- )
-);
diff --git a/dev-php/phpdepend/metadata.xml b/dev-php/phpdepend/metadata.xml
deleted file mode 100644
index a55636ecfa83..000000000000
--- a/dev-php/phpdepend/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
- <upstream>
- <remote-id type="github">pdepend/pdepend</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-php/phpdepend/phpdepend-2.5.0-r1.ebuild b/dev-php/phpdepend/phpdepend-2.5.0-r1.ebuild
deleted file mode 100644
index 1ea5cc4ab920..000000000000
--- a/dev-php/phpdepend/phpdepend-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN=pdepend
-
-DESCRIPTION="Static code analysis for PHP"
-HOMEPAGE="http://www.pdepend.org/"
-
-# The test suite is absent from the release tarballs because
-# the only build system that Composer understands is "cp -r".
-# To obtain the tests, we would need to grab a VCS snapshot.
-SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-lang/php
- dev-php/fedora-autoloader
- >=dev-php/symfony-config-2.3
- >=dev-php/symfony-dependency-injection-2.3
- >=dev-php/symfony-filesystem-2.3"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_install() {
- dodoc CHANGELOG
-
- # The executable will only look for autoload.php in one place, so we
- # create an (otherwise pointless) vendor directory to house it.
- insinto "/usr/share/${PN}/vendor"
- doins "${FILESDIR}/autoload.php"
-
- insinto "/usr/share/${PN}/src"
- doins -r src/main
-
- # The executable uses relative include paths, so the one users will
- # actually run needs to be symlinked into the source tree.
- exeinto "/usr/share/${PN}/src/bin"
- doexe "src/bin/${MY_PN}"
- dosym "../share/${PN}/src/bin/${MY_PN}" "/usr/bin/${MY_PN}"
-}