summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-06-11 12:00:09 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-06-11 12:33:57 -0400
commit32b2c815db134001ca71aa93e3b65f050461f1d0 (patch)
treeb7fc4dac59c3ef79fe0f5165742bfd0a4b9086f1 /dev-php
parentmedia-video/subtitlecomposer: add 0.8.1 (diff)
downloadgentoo-32b2c815db134001ca71aa93e3b65f050461f1d0.tar.gz
gentoo-32b2c815db134001ca71aa93e3b65f050461f1d0.tar.bz2
gentoo-32b2c815db134001ca71aa93e3b65f050461f1d0.zip
dev-php/PEAR-Crypt_GPG: add 1.6.9
Bump to EAPI=8 and drop the test suite, since it required PHPUnit, and PHPUnit is no longer packaged. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Crypt_GPG/Manifest1
-rw-r--r--dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_GPG/Manifest b/dev-php/PEAR-Crypt_GPG/Manifest
index 7209c7c0e908..c285c39b79c1 100644
--- a/dev-php/PEAR-Crypt_GPG/Manifest
+++ b/dev-php/PEAR-Crypt_GPG/Manifest
@@ -1 +1,2 @@
DIST Crypt_GPG-1.6.7.tgz 343957 BLAKE2B c95346005fdd36bd97e2a0e6cd42c5a2898fb59f0a4a3d3b09bd99a409bd9c998b267ffd84ab28148e17c3f7e78e094393c3b077998b05dc2d7ddcb0ab81394b SHA512 dd629271ebbcb98df5d31313c1a6911b62964046c758e00b55377170653e9880d2edc7d0b953fd6ae441d74238c4a8e1008bf6a9195a19ff463bcc82665f14e8
+DIST Crypt_GPG-1.6.9.tgz 344282 BLAKE2B d8546a34a70e8379b8003824636b26ad289f8c906bfbbf5c90cc5655f1bda243c57ec077a497e2a69c09bd5febd65a3f2cd39b426aadbf4f13e5ba10f6ed2380 SHA512 e3493406f27f73539522fa16cdd01aa940faacc6b180228b718596c6803c6c6a6cbb68c244749da965a62d19abc50bff83210d798f9394fde8980c5d8c8cdb2d
diff --git a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.9.ebuild b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.9.ebuild
new file mode 100644
index 000000000000..55eaa8d81a27
--- /dev/null
+++ b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="PHP interface to the GNU Privacy Guard (GnuPG)"
+HOMEPAGE="https://pear.php.net/package/Crypt_GPG"
+SRC_URI="https://download.pear.php.net/package/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~sparc ~x86"
+
+RDEPEND="app-crypt/gnupg
+ dev-lang/php:*[posix(-),unicode(-)]
+ dev-php/PEAR-Console_CommandLine
+ dev-php/PEAR-Exception"
+
+src_prepare() {
+ default
+
+ sed -i "s|@bin-dir@|${EPREFIX}/usr/bin|" Crypt/GPG/Engine.php || die
+ sed -i "s|@package-name@|${MY_PN}|" Crypt/GPG/PinEntry.php || die
+ sed -i "s|@data-dir@|${EPREFIX}/usr/share|" Crypt/GPG/PinEntry.php || die
+}
+
+src_install() {
+ dodoc README.md
+ dobin scripts/crypt-gpg-pinentry
+
+ insinto "/usr/share/${MY_PN}"
+ doins -r data
+
+ insinto /usr/share/php
+ doins -r Crypt
+}