summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-11-15 09:44:26 -0500
committerBrian Evans <grknight@gentoo.org>2016-11-15 09:44:26 -0500
commit35939bb11b896401cfe97729e88d31742d5f0ffe (patch)
tree6b68df09371a643d22136096e59ab6cc955283b3 /dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
parentsys-devel/llvm: Remove 3.5.0 (diff)
downloadgentoo-35939bb11b896401cfe97729e88d31742d5f0ffe.tar.gz
gentoo-35939bb11b896401cfe97729e88d31742d5f0ffe.tar.bz2
gentoo-35939bb11b896401cfe97729e88d31742d5f0ffe.zip
dev-php/pecl-ssh2: Add live ebuild wrt bug 599750
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
new file mode 100644
index 000000000000..009cd7eec1f3
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php7-0 php5-6"
+EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
+
+inherit php-ext-source-r3 git-r3
+
+USE_PHP="php7-0"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+KEYWORDS=""
+DEPEND=">=net-libs/libssh2-1.2"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+HOMEPAGE="https://pecl.php.net/package/ssh2"
+PHP_EXT_ECONF_ARGS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ php-ext-source-r3_src_unpack
+}
+
+src_prepare() {
+ if use php_targets_php7-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}