summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-gearman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-gearman')
-rw-r--r--dev-php/pecl-gearman/Manifest1
-rw-r--r--dev-php/pecl-gearman/metadata.xml12
-rw-r--r--dev-php/pecl-gearman/pecl-gearman-1.0.2-r1.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-gearman/Manifest b/dev-php/pecl-gearman/Manifest
new file mode 100644
index 000000000000..5e30bf402bf0
--- /dev/null
+++ b/dev-php/pecl-gearman/Manifest
@@ -0,0 +1 @@
+DIST gearman-1.0.2.tgz 30405 SHA256 fd4bb531b9dbac5d7816254ae659155baf43a53addcec2a911852741d1194402 SHA512 503d16912bc7de6a3b348fef76eada4e0125636d4c75cc3361b39811efa6df020147c48116eceb7478fa76234491c70eab2974e45a7b2c5900810de272bec702 WHIRLPOOL 08270c7a01e97d246ac0ac3e11e76e8a6ef2531a0c382ffd9b495c69324d3b4e2fc5c323b86e851960e672ad53b3a65c9c85be81d46cde303e00d36bdcb066a0
diff --git a/dev-php/pecl-gearman/metadata.xml b/dev-php/pecl-gearman/metadata.xml
new file mode 100644
index 000000000000..21b6378eedbc
--- /dev/null
+++ b/dev-php/pecl-gearman/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>pavel.stratil-jun@fenix.cz</email>
+ <description>Proxied co-maintainer, assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-gearman/pecl-gearman-1.0.2-r1.ebuild b/dev-php/pecl-gearman/pecl-gearman-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..870bc7c4d0a0
--- /dev/null
+++ b/dev-php/pecl-gearman/pecl-gearman-1.0.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_EXT_NAME="gearman"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4 "
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension for using gearmand"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-cluster/gearmand-0.21"
+RDEPEND="${DEPEND}"