summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-Log
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/Manifest2
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.12.7-r1.ebuild24
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.12.8.ebuild17
-rw-r--r--dev-php/PEAR-Log/metadata.xml5
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/PEAR-Log/Manifest b/dev-php/PEAR-Log/Manifest
new file mode 100644
index 000000000000..af3af73f8dfb
--- /dev/null
+++ b/dev-php/PEAR-Log/Manifest
@@ -0,0 +1,2 @@
+DIST Log-1.12.7.tgz 46898 SHA256 7db9d8dae364e3cde16de2087a371eb862479f33d32631db947620b20d2306c0 SHA512 1c1bed9bb73a729ff8a48ed1ae0aca63384c6a14217a0aca6f9be886c1b477a07bc38a3a169e1c32430efb1b63c265fd705929e4ee5e18444f8c518a13997fc7 WHIRLPOOL d5011b48f3b1880764b2d3b1f1deeec5cf061f3e75639ab7e790e87f8551bb0b36d3ed63f33f1483314dd056e2280f8690ee92290ef11ca3f2e9d2de3cf85e7e
+DIST Log-1.12.8.tgz 46725 SHA256 2f6c27ea105b401bda3b31f2a50a20cf54ca6eda175f045db1b4251b073799b3 SHA512 ab382fe684818ed6cc5f14a4ee5df8b89cf6f9b6e110368be5b4986fe8013e185b37f9385190a85f6ff22ac3191853a96914643d3a6e4c02535927e40df7a1fe WHIRLPOOL cd904c2d5180953cecafdbb73d15ef64473245e001a087cdf351cb8062f5ca296f8c704ff2b1f6a80eff1b17f2271fec6f4eea1970b3a55df1414859176b7180
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.12.7-r1.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.12.7-r1.ebuild
new file mode 100644
index 000000000000..c0023489cba8
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.12.7-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit php-pear-r1
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+
+DESCRIPTION="The Log framework provides an abstracted logging system.@"
+LICENSE="MIT"
+SLOT="0"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-Mail
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+pkg_postinst() {
+ if ! use minimal && ! has_version dev-lang/php[sqlite] ; then
+ elog "${PN} can optionally use dev-lang/php's sqlite features."
+ elog "If you want those, recompile dev-lang/php with this flag in USE."
+ fi
+}
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.12.8.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.12.8.ebuild
new file mode 100644
index 000000000000..e0973048544e
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.12.8.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit php-pear-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="The Log framework provides an abstracted logging system"
+LICENSE="MIT"
+SLOT="0"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-Mail
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
diff --git a/dev-php/PEAR-Log/metadata.xml b/dev-php/PEAR-Log/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Log/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>