summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2024-06-29 13:15:28 +0200
committerLuca Barbato <lu_zero@gentoo.org>2024-06-29 21:26:15 +0200
commit746867587754355b9aa2c69c6e4b6eac31747d81 (patch)
treeb05886efc0083356a7c6cb0b1b4d0bc7f97e29fd /dev-perl
parentmedia-libs/libjxl: Stabilize 0.9.2-r1 ppc64, #935114 (diff)
downloadgentoo-746867587754355b9aa2c69c6e4b6eac31747d81.tar.gz
gentoo-746867587754355b9aa2c69c6e4b6eac31747d81.tar.bz2
gentoo-746867587754355b9aa2c69c6e4b6eac31747d81.zip
dev-perl/Net-SSLeay: Remove a runtime check for the libssl version
It breaks cross-emerge and should be redundant for us. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.940.0.ebuild1
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.940.0-avoid-runtime-check.patch26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.940.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.940.0.ebuild
index b6b76ace6618..525f892ef56c 100644
--- a/dev-perl/Net-SSLeay/Net-SSLeay-1.940.0.ebuild
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.940.0.ebuild
@@ -36,6 +36,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
+ "${FILESDIR}/${PN}-1.940.0-avoid-runtime-check.patch"
)
PERL_RM_FILES=(
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.940.0-avoid-runtime-check.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.940.0-avoid-runtime-check.patch
new file mode 100644
index 000000000000..ed6019060926
--- /dev/null
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.940.0-avoid-runtime-check.patch
@@ -0,0 +1,26 @@
+From 5219e8c5181b3a819b89032766340d5c1b11c3c5 Mon Sep 17 00:00:00 2001
+From: Luca Barbato <lu_zero@gentoo.org>
+Date: Sat, 29 Jun 2024 21:10:06 +0200
+Subject: [PATCH] Remove the runtime check
+
+Makes simpler to cross-build. At least for Gentoo it is fine since we
+control the versions on our own.
+---
+ Makefile.PL | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 94c72f2..d4b1aea 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -196,7 +196,6 @@ EOM
+ exit MISSING_PREREQ;
+ }
+
+- check_openssl_version($prefix, $exec);
+ my %args = (
+ CCCDLFLAGS => $opts->{cccdlflags},
+ OPTIMIZE => $opts->{optimize},
+--
+2.45.2
+