summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-08 10:13:49 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-08 10:14:16 +1300
commit11ba43fdd2cf2562ab39ec3bc3b8b56edfbb8330 (patch)
treec62b3ed91ac2408b5f7b659b2b54fa168d304ddf /dev-perl
parentdev-perl/Digest-GOST: Add w/ version 0.60.0 (diff)
downloadgentoo-11ba43fdd2cf2562ab39ec3bc3b8b56edfbb8330.tar.gz
gentoo-11ba43fdd2cf2562ab39ec3bc3b8b56edfbb8330.tar.bz2
gentoo-11ba43fdd2cf2562ab39ec3bc3b8b56edfbb8330.zip
dev-perl/Net-DNS: Bump to version 1.70.0
- Add demo/ and contrib/ dir as USE=examples - Add missing recommended deps Upstream: - Fix TSIG.pm - Fix ::Async being unable to retry truncated UDP using TCP - Fix hanging in recursive resolving - Fix dying on scoped IPv6 nameserver addresses - Fix case sensitive compression breaking resolver->nameservers - Net::DNS::ZoneFile no longer fails when unnamed RR follows ORIGIN - Fix compile with taint - ::ZoneFile no longer fails parsing mixed case mnemonics - ::Nameserver now supports EDNS replies Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Net-DNS/Manifest1
-rw-r--r--dev-perl/Net-DNS/Net-DNS-1.70.0.ebuild59
-rw-r--r--dev-perl/Net-DNS/metadata.xml23
3 files changed, 80 insertions, 3 deletions
diff --git a/dev-perl/Net-DNS/Manifest b/dev-perl/Net-DNS/Manifest
index 1b1e7b7098d6..48e98a93f675 100644
--- a/dev-perl/Net-DNS/Manifest
+++ b/dev-perl/Net-DNS/Manifest
@@ -1 +1,2 @@
DIST Net-DNS-1.04.tar.gz 245064 SHA256 4b9f220304c5722658fbdbe4db31ab77486b5f0aaada78c9d1b528e4b0680965 SHA512 ff32c1bf52e553fcd64f8a0f9fcd30f6eae4e1350c4c5c97da3b745f1713acd75533694ec834e1b1e9bee0a13b7a8ee0c347dfaa36433052f020e41e36829d59 WHIRLPOOL 5c09639ffc7bdaac4625bf9fc592c6109b43ebb7ab0eed29b9bb7cc42d35f155736a9125787adabb3ee47fb2374189b9d940ea6bf626fa8d837cd5be2511ea83
+DIST Net-DNS-1.07.tar.gz 256114 SHA256 5f91497f1af9f690153fa05a27a7d73ddada08bed40536fe2d0ac759b7af8492 SHA512 048cf6c4fb5e8c5721f5c43cc6f3f93189854c54745ab569b2537a1765cbbe4c360b484290d3151a0d0875b8e8a63b15a4ec97cda7f723f5b7be0078f903fb9f WHIRLPOOL 17c6ce70591f1f98b5c266b6884527dbdefd9fabb74ad0c451e752b14501bb7ab09a08d3403904fc985f0e6eb0e10a10378e9b544e03386930a7408f94fe4fa9
diff --git a/dev-perl/Net-DNS/Net-DNS-1.70.0.ebuild b/dev-perl/Net-DNS/Net-DNS-1.70.0.ebuild
new file mode 100644
index 000000000000..a40a44dcf91c
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-1.70.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.07
+DIST_EXAMPLES=( "contrib" "demo" )
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 test minimal"
+
+PDEPEND="!minimal? ( >=dev-perl/Net-DNS-SEC-1.10.0 )"
+RDEPEND="
+ >=dev-perl/Digest-HMAC-1.30.0
+ >=virtual/perl-Digest-MD5-2.130.0
+ >=virtual/perl-Digest-SHA-5.230.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-MIME-Base64-2.110.0
+ >=virtual/perl-Time-Local-1.190.0
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )
+ !minimal? (
+ >=dev-perl/Digest-BubbleBabble-0.10.0
+ >=dev-perl/Digest-GOST-0.60.0
+ >=virtual/perl-IO-Socket-IP-0.320.0
+ >=dev-perl/IO-Socket-INET6-2.510.0
+ >=dev-perl/Net-LibIDN-0.120.0
+ >=virtual/perl-Scalar-List-Utils-1.250.0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+src_test() {
+ perl_rm_files t/00-pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Net-DNS/metadata.xml b/dev-perl/Net-DNS/metadata.xml
index b36f2ae1484f..83de420a2928 100644
--- a/dev-perl/Net-DNS/metadata.xml
+++ b/dev-perl/Net-DNS/metadata.xml
@@ -26,15 +26,25 @@
<remote-id type="cpan-module">Net::DNS::RR::AFSDB</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::APL</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::APL::Item</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::CAA</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::CDNSKEY</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::CDS</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::CERT</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::CNAME</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::CSYNC</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::DHCID</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::DLV</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::DNAME</remote-id>
- <remote-id type="cpan-module">Net::DNS::RR::EID</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::DNSKEY</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::DS</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::EUI48</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::EUI64</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::GPOS</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::HINFO</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::HIP</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::IPSECKEY</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::ISDN</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::KEY</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::KX</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::L32</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::L64</remote-id>
@@ -47,15 +57,20 @@
<remote-id type="cpan-module">Net::DNS::RR::MX</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NAPTR</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NID</remote-id>
- <remote-id type="cpan-module">Net::DNS::RR::NIMLOC</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NS</remote-id>
- <remote-id type="cpan-module">Net::DNS::RR::NSAP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NSEC</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NSEC3</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NSEC3PARAM</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NULL</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::OPENPGPKEY</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::OPT</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::PTR</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::PX</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::RP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::RRSIG</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::RT</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::SIG</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::SMIMEA</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::SOA</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::SPF</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::SRV</remote-id>
@@ -64,12 +79,14 @@
<remote-id type="cpan-module">Net::DNS::RR::TLSA</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::TSIG</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::TXT</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::URI</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::X25</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver::Base</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver::MSWin32</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver::Recurse</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver::UNIX</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::android</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver::cygwin</remote-id>
<remote-id type="cpan-module">Net::DNS::Resolver::os2</remote-id>
<remote-id type="cpan-module">Net::DNS::Text</remote-id>