summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-18 00:02:40 +0100
committerSam James <sam@gentoo.org>2023-06-18 00:17:35 +0100
commit2f12e6d2a594e1827fcafffa4b0997b92374f436 (patch)
tree507329549bd234d299f862a726caa050f08c8e96 /dev-perl/YAML-Tiny
parentdev-perl/Test-Without-Module: add 0.210.0 (diff)
downloadgentoo-2f12e6d2a594e1827fcafffa4b0997b92374f436.tar.gz
gentoo-2f12e6d2a594e1827fcafffa4b0997b92374f436.tar.bz2
gentoo-2f12e6d2a594e1827fcafffa4b0997b92374f436.zip
dev-perl/YAML-Tiny: add 1.740.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/YAML-Tiny')
-rw-r--r--dev-perl/YAML-Tiny/Manifest1
-rw-r--r--dev-perl/YAML-Tiny/YAML-Tiny-1.740.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/YAML-Tiny/Manifest b/dev-perl/YAML-Tiny/Manifest
index 336bedf94efb..8f800dea9a7f 100644
--- a/dev-perl/YAML-Tiny/Manifest
+++ b/dev-perl/YAML-Tiny/Manifest
@@ -1 +1,2 @@
DIST YAML-Tiny-1.73.tar.gz 73708 BLAKE2B 42e9c5cffa2b9babb0dd1453af69866405fd7273c2b340ceb010d78d8fe28db61268b6bb5ad1840b1aa72819ae048150bf5c416bed1b2e518b28f77b2ba978be SHA512 5999e220025aa8076e5e0e9e73e80c2da21660e77f6744d73e8e29962221d02d33a36e9829c44abf7d4f45abae069d8e121c8019bd1600b7e64db5e54efd9987
+DIST YAML-Tiny-1.74.tar.gz 75036 BLAKE2B 0a5be9a5ee2a1d87dbf660c43d9a962f1f7ebaa382f649357fab4508f4b205c737b51850bf660ac56c684fd465922ae1fc1efbafd527b9ae4d3adf7b73c4992e SHA512 2da59bf583b09a60e8e1bac7c21fc4300ae3ee2092ffd77cbf3778c65c7d0bdf68fa3616665d276f4d4df2437526d36d497ac53be79baa182f84f37640bfcad4
diff --git a/dev-perl/YAML-Tiny/YAML-Tiny-1.740.0.ebuild b/dev-perl/YAML-Tiny/YAML-Tiny-1.740.0.ebuild
new file mode 100644
index 000000000000..1a1d76d17a04
--- /dev/null
+++ b/dev-perl/YAML-Tiny/YAML-Tiny-1.740.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=1.74
+inherit perl-module
+
+DESCRIPTION="Read/Write YAML files with as little code as possible"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/JSON-MaybeXS-1.1.0
+ )
+ >=virtual/perl-File-Spec-0.80.0
+ >=virtual/perl-File-Temp-0.190.0
+ virtual/perl-Getopt-Long
+ virtual/perl-IO
+ virtual/perl-JSON-PP
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"