summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 20:06:55 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 20:07:32 +1300
commitdbd810acd7ca84e9359926edc54adf8172e89f12 (patch)
tree3592ebd2a474cc9890fc1f1e8789d8f5fa78e3e8 /dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild
parentapp-portage/g-sorcery-0.2.1-r1: added ~mips, bug 524040 (diff)
downloadgentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.tar.gz
gentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.tar.bz2
gentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.zip
dev-perl/XML-SAX: Bump to version 1.0.0
- EAPI6 - Enable parallel tests - Rework auto-ini-generation removal logic as a patch - Cease using encodings.patch which now appears of little value ( was included as part of #127735 but the fix that fixed that issue is long upstreamed and tests indicate it no longer relevant ) Upstream: - Build order fixes for vanilla installs Bug: https://bugs.gentoo.org/127735 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild')
-rw-r--r--dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild b/dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild
new file mode 100644
index 000000000000..a6ecf0690138
--- /dev/null
+++ b/dev-perl/XML-SAX/XML-SAX-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRANTM
+DIST_VERSION=1.00
+inherit perl-module eutils
+
+DESCRIPTION="Perl module for using and building Perl SAX2 XML parsers, filters, and drivers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/XML-SAX-Base-1.50.0
+ >=dev-perl/XML-NamespaceSupport-1.40.0
+ >=dev-libs/libxml2-2.4.1
+ virtual/perl-File-Temp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=("${FILESDIR}/${PN}-1.00-noautoini.patch")
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::PurePerl
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}