summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-24 20:10:38 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-24 20:10:59 +1300
commit2a264214762e5cb3c31b877f1868998f9b041b36 (patch)
tree7acc81fb2f28e47388d42c4e86b82ada75f22842 /dev-perl/HTML-Formatter/HTML-Formatter-2.160.0.ebuild
parentdev-perl/HTML-Format: Remove, gone to HTML-Formatter (diff)
downloadgentoo-2a264214762e5cb3c31b877f1868998f9b041b36.tar.gz
gentoo-2a264214762e5cb3c31b877f1868998f9b041b36.tar.bz2
gentoo-2a264214762e5cb3c31b877f1868998f9b041b36.zip
dev-perl/HTML-Formatter: Bump to version 2.160.0
Upstream: - Fix test failures - Fix Markdown fragment handling - Improved UTF8 Support Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/HTML-Formatter/HTML-Formatter-2.160.0.ebuild')
-rw-r--r--dev-perl/HTML-Formatter/HTML-Formatter-2.160.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/HTML-Formatter/HTML-Formatter-2.160.0.ebuild b/dev-perl/HTML-Formatter/HTML-Formatter-2.160.0.ebuild
new file mode 100644
index 000000000000..8a236d55303a
--- /dev/null
+++ b/dev-perl/HTML-Formatter/HTML-Formatter-2.160.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NIGELM
+DIST_VERSION=2.16
+inherit perl-module
+
+DESCRIPTION="Base class for HTML Formatters"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ dev-perl/Font-AFM
+ dev-perl/HTML-Tree
+ virtual/perl-IO
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/File-Slurper
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Warnings
+ )
+"
+src_test() {
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_test
+}