summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-17 11:57:07 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-17 23:20:37 +0100
commitfc7ef364ffae27887612b1f02b800e0e085e830a (patch)
tree8fdd452a17d7e4a641bb6b77f814aed55a9598db /dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild
parentdev-haskell/hpc: allow ghc-7.10.3, bug #577616 (diff)
downloadgentoo-fc7ef364ffae27887612b1f02b800e0e085e830a.tar.gz
gentoo-fc7ef364ffae27887612b1f02b800e0e085e830a.tar.bz2
gentoo-fc7ef364ffae27887612b1f02b800e0e085e830a.zip
dev-perl/DBIx-Simple: Add to tree at 1.350.0-r1
Required for dev-perl/Mail-DMARC Previously maintained in perl-experimental since Dec 2008 my Torsten Veller, Michele Beltrame and Kent Fredric -r1 bump to ensure an upgrade from overlay Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild')
-rw-r--r--dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild b/dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild
new file mode 100644
index 000000000000..9c2df80929a0
--- /dev/null
+++ b/dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=JUERD
+DIST_VERSION=1.35
+inherit perl-module
+
+DESCRIPTION="Very complete easy-to-use OO interface to DBI"
+
+# Upstream says "Any OSI approved license from https://opensource.org/licenses/alphabetical"
+LICENSE="|| ( AFL-3.0 AGPL-3 APL-1.0 Apache-2.0 BSD-2 Boost-1.0 CDDL CPAL-1.0
+ EPL-1.0 ECL-2.0 EUPL-1.1 GPL-2 GPL-3 LGPL-2.1 LGPL-3 HPND IBM IPAfont ISC
+ LPPL-1.3c 9base MIT MPL-2.0 NOSA nethack PHP-3 POSTGRESQL PYTHON CNRI
+ QPL-1.0 OFL-1.1 Sleepycat Watcom-1.0 W3C wxWinLL-3 ZLIB libpng
+)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ >=dev-perl/DBI-1.210.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( !minimal? (
+ >=dev-perl/DBD-SQLite-1.0.0
+ ) )
+"
+src_test() {
+ perl_rm_files "t/pod.t"
+ perl-module_src_test
+}