summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Class-C3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Class-C3')
-rw-r--r--dev-perl/Class-C3/Class-C3-0.250.0-r1.ebuild24
-rw-r--r--dev-perl/Class-C3/Class-C3-0.280.0.ebuild30
-rw-r--r--dev-perl/Class-C3/Manifest2
-rw-r--r--dev-perl/Class-C3/metadata.xml9
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-perl/Class-C3/Class-C3-0.250.0-r1.ebuild b/dev-perl/Class-C3/Class-C3-0.250.0-r1.ebuild
new file mode 100644
index 000000000000..51f9aa50a93f
--- /dev/null
+++ b/dev-perl/Class-C3/Class-C3-0.250.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSTROUT
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="A pragma to use the C3 method resolution order algortihm"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~ppc-aix ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ || ( >=dev-lang/perl-5.10
+ >=dev-perl/Class-C3-XS-0.07 )"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST=do
diff --git a/dev-perl/Class-C3/Class-C3-0.280.0.ebuild b/dev-perl/Class-C3/Class-C3-0.280.0.ebuild
new file mode 100644
index 000000000000..a361a034f580
--- /dev/null
+++ b/dev-perl/Class-C3/Class-C3-0.280.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAARG
+MODULE_VERSION=0.28
+inherit perl-module
+
+DESCRIPTION="A pragma to use the C3 method resolution order algortihm"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Algorithm-C3-0.70.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-CBuilder-0.270.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Class-C3/Manifest b/dev-perl/Class-C3/Manifest
new file mode 100644
index 000000000000..cec6bd2779b5
--- /dev/null
+++ b/dev-perl/Class-C3/Manifest
@@ -0,0 +1,2 @@
+DIST Class-C3-0.25.tar.gz 39566 SHA256 344506d60e2e5b045a3bdeba7925cc0d5e1e161129ee44131a8c2a3a4d4acf4f SHA512 6c61f85d60869173d726f05debc018575118b4856065ce17fad82d56c279f76b3a68ec9d3286648834833fe696dae27f38f96813767c9a51a43f84355805175c WHIRLPOOL adc2c76c9fcde122ccf03671916c9762350badfcbf05b9caae36e967ff4cb61143ff5a3f18e3a7e83f3e4a56352658ca7ecbf1dd7688831aca70d2e7b5745df0
+DIST Class-C3-0.28.tar.gz 25641 SHA256 6f91ed2adc489210d11efca4af79d8939f74fa5bbb312f9d887538e736138d20 SHA512 2f503f1261eb8bff9a5dc8d55ef5af59ae6968994b4789e7875149bf708edb304ce8895de3cf717ed574de1f4530d2426da11598789e87292ac02594d162c87e WHIRLPOOL 9ca6d2a5f8d1cf6987bad15443cb65dd03257532ff4bca5cdb5b5678356485495ffaedd82ccfaa6da8afa41b2b6bfbb47ef1eef976882081a92bf4b8d5f4838b
diff --git a/dev-perl/Class-C3/metadata.xml b/dev-perl/Class-C3/metadata.xml
new file mode 100644
index 000000000000..fcc1d688cec1
--- /dev/null
+++ b/dev-perl/Class-C3/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Class-C3</remote-id>
+ <remote-id type="cpan-module">Class::C3</remote-id>
+ </upstream>
+</pkgmetadata>