summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 03:39:49 +0000
committerSam James <sam@gentoo.org>2021-11-06 03:39:49 +0000
commitc44d34624a40c83f5e775678e4f080b604326a99 (patch)
treec77c03b75d257998c8cff0e0cb070778d475e709 /dev-ml
parentdev-ml/opam-solver: fix 2.0.10 (diff)
downloadgentoo-c44d34624a40c83f5e775678e4f080b604326a99.tar.gz
gentoo-c44d34624a40c83f5e775678e4f080b604326a99.tar.bz2
gentoo-c44d34624a40c83f5e775678e4f080b604326a99.zip
dev-ml/opam-installer: fix 2.0.10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.10.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-ml/opam-installer/opam-installer-2.0.10.ebuild b/dev-ml/opam-installer/opam-installer-2.0.10.ebuild
index 1ea426a6380d..a2b88905a299 100644
--- a/dev-ml/opam-installer/opam-installer-2.0.10.ebuild
+++ b/dev-ml/opam-installer/opam-installer-2.0.10.ebuild
@@ -6,21 +6,20 @@ EAPI=7
# We are opam
OPAM_INSTALLER_DEP=" "
OPAM_SKIP_VALIDATION=yes
-inherit dune
+inherit opam
DESCRIPTION="Core installer for opam packages"
HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
S="${WORKDIR}/opam-full-${PV/_/-}"
-OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
+OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+ocamlopt"
-PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
RDEPEND="
>=dev-lang/ocaml-4.02.3
@@ -38,3 +37,10 @@ src_configure() {
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--mandir="${EPREFIX}/usr/share/man"
}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}