summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-06-30 21:50:46 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-06-30 22:05:27 +0200
commita8bd510c925a58143a383167f538168e79b328d3 (patch)
treee5513207412a2e2143e9076722dc4b9deab9127f /dev-ml
parentdev-ml/ppx_variants_conv: add 0.16.0 (diff)
downloadgentoo-a8bd510c925a58143a383167f538168e79b328d3.tar.gz
gentoo-a8bd510c925a58143a383167f538168e79b328d3.tar.bz2
gentoo-a8bd510c925a58143a383167f538168e79b328d3.zip
dev-ml/ppx_typerep_conv: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_typerep_conv/Manifest1
-rw-r--r--dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.16.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_typerep_conv/Manifest b/dev-ml/ppx_typerep_conv/Manifest
index 9e6e7d1d1068..506935e8cf2d 100644
--- a/dev-ml/ppx_typerep_conv/Manifest
+++ b/dev-ml/ppx_typerep_conv/Manifest
@@ -1,3 +1,4 @@
DIST ppx_typerep_conv-0.14.1.tar.gz 9453 BLAKE2B 4acafdd51df0659746697283aa3240f1b1403e4e9f9b5fafa6c4b09f4c76f6ac645e2ccab53cba7371b5b004edba38d24198334d10b295d90c8ba5814a602a23 SHA512 6e32f6c2cf6c370fcb8d3b341dbd797c3b7c2557c8604253d744b266c9a3f4984e62ffe6ec5717044378f81e5b78e7f206a7f0f4b43c0dda97a4e7ece745d26d
DIST ppx_typerep_conv-0.14.2.tar.gz 9474 BLAKE2B 7a7ff6669d9af2ced905e5b104058d26ffe06e3784af366a1a4ce753337eeb87c9bfe02d1a6fddaac6c387105d2583194cbd06b915eb35d16e06b1d4ab977e2f SHA512 9372f13cb3f62b3732af4f8ddc00314dd71869bab5599ae0a112d32669de300346781b7fcd2bd649ccedfde54fcd86fb6186812eeb528858048bcd9d5ad443dd
DIST ppx_typerep_conv-0.15.0.tar.gz 9392 BLAKE2B 3f7d9ac373048434ea55deab18b25bd74da77116b20db841c412c3304f318a1b820708c3f9cb6eab1f92fda399d3e6168fc8b3cc0546501f4fc6b57da5f74414 SHA512 3f5bb2c70674e5f6219daa883fe948023a60558c9560c5d8e6b187e0420adf8767ce4f5cca06fe7edccd52e531b2e79d962f7fdc7502cb63280c364627621c73
+DIST ppx_typerep_conv-0.16.0.tar.gz 9421 BLAKE2B dbef20e205e550ab4ef16cf0e53bb47567b922297818a944a3fb6cd07eee90c6184d9cd33d7fc2e67b47fd371c95410f7022a8e140c9946c1c7502bb2a433d0c SHA512 842f3caeb22b7d1feb1de9f599ffe2474365704e7ce9c05366b9714bcbf165791eda8b16d420a3a64ccc8ea44a9b2178ffddaa8e3ad005c6536c3559f2da295a
diff --git a/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.16.0.ebuild b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.16.0.ebuild
new file mode 100644
index 000000000000..2810a82752c1
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of runtime types from type declarations"
+HOMEPAGE="https://github.com/janestreet/ppx_typerep_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/typerep:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"