summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-09 01:43:48 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-09 01:43:57 +0100
commit10aac9c81db5f712cb6ed987de50e0f5bad50c6e (patch)
tree450c948d655af46c213d659eb43b147219b9eae1 /dev-ml
parentsys-firmware/edk2-ovmf: keyword 202202 for -* (diff)
downloadgentoo-10aac9c81db5f712cb6ed987de50e0f5bad50c6e.tar.gz
gentoo-10aac9c81db5f712cb6ed987de50e0f5bad50c6e.tar.bz2
gentoo-10aac9c81db5f712cb6ed987de50e0f5bad50c6e.zip
dev-ml/ocaml-fileutils: fix deps and dune build without seq
Closes: https://bugs.gentoo.org/884127 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-fileutils/files/ocaml-fileutils-0.6.4-dune.patch8
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild (renamed from dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild)16
2 files changed, 17 insertions, 7 deletions
diff --git a/dev-ml/ocaml-fileutils/files/ocaml-fileutils-0.6.4-dune.patch b/dev-ml/ocaml-fileutils/files/ocaml-fileutils-0.6.4-dune.patch
new file mode 100644
index 000000000000..5a0eb479bdbc
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/files/ocaml-fileutils-0.6.4-dune.patch
@@ -0,0 +1,8 @@
+--- a/src/lib/fileutils/dune
++++ b/src/lib/fileutils/dune
+@@ -30,4 +30,4 @@
+ fileUtilWHICH
+ unixPath
+ win32Path)
+- (libraries unix seq stdlib-shims))
++ (libraries unix stdlib-shims))
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild
index 04a39c41c268..37311d0f25e8 100644
--- a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild
@@ -1,25 +1,27 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DUNE_PKG_NAME="fileutils"
+DUNE_PKG_NAME=fileutils
inherit dune
DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-${PV}.tbz -> ${P}.tar.bz2"
+S="${WORKDIR}"/${DUNE_PKG_NAME}-${PV}
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
-DEPEND=">=dev-ml/ounit2-2.0.0
- >=dev-ml/stdlib-shims-0.2.0"
+DEPEND="dev-ml/stdlib-shims:="
RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"
-DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+PATCHES=( "${FILESDIR}"/${P}-dune.patch )
-S="${WORKDIR}/${DUNE_PKG_NAME}-${PV}"
+DOCS=( CHANGES.md LICENSE.txt README.md )