summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 10:03:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 10:20:08 +0100
commit2acee6d5bf58b8336fe6c07422e775459df50151 (patch)
treee24191902cae71cad5a5533cd65823bed6f3c9da /dev-ml/ppx_optcomp
parentdev-ml/ppx_pipebang: bump to 113.33.00 (diff)
downloadgentoo-2acee6d5bf58b8336fe6c07422e775459df50151.tar.gz
gentoo-2acee6d5bf58b8336fe6c07422e775459df50151.tar.bz2
gentoo-2acee6d5bf58b8336fe6c07422e775459df50151.zip
dev-ml/ppx_optcomp: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_optcomp')
-rw-r--r--dev-ml/ppx_optcomp/Manifest1
-rw-r--r--dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppx_optcomp/Manifest b/dev-ml/ppx_optcomp/Manifest
index 399b111e8783..3f24bb47a49b 100644
--- a/dev-ml/ppx_optcomp/Manifest
+++ b/dev-ml/ppx_optcomp/Manifest
@@ -1 +1,2 @@
DIST ppx_optcomp-113.24.00.tar.gz 56740 SHA256 5abd8c7b07ac20efdc549df127ee5e7f169ebd88fe95e7d0711d6fbe4dc4b6d6 SHA512 6f2e03b428060282a987ca6087609aeca5596007c6b67c8aa463efcb97be5a3277805e0fd4e0835c8af5f46f9223345ba84acc93fcc6bb034910e6d240a6d549 WHIRLPOOL 74c33f9c78ab29d3e6c3dabcff609a05d619eac94b1ef6b4319821e29b5341ac455f8f15b62fcd65afa79aff1b182f73b29b12c36fdf0ae2c798ab72bfde37c9
+DIST ppx_optcomp-113.33.00.tar.gz 59227 SHA256 b2a3140a03dff8314bcca84a3d0691f3c1d78172cbb6c03390c7952f9b7747c1 SHA512 956cb3007d4c13eac789e02f7f132c3ef153af5d3ae7d69aea3e8a10395a0984bc48e136c7dc6b245aebcc193a05cb47493873f9952e65765310c28a7242be63 WHIRLPOOL 906a4ac35c05d89f2001f831049688205e4647d766b05a3af1f751cd3fed84de616011f015df76973aa2e8cde6640ff52353861eece51b5409b4000e201381d7
diff --git a/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild b/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
new file mode 100644
index 000000000000..a644d2daa385
--- /dev/null
+++ b/dev-ml/ppx_optcomp/ppx_optcomp-113.33.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Optional compilation for OCaml"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:="
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}