summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-14 08:51:06 +0100
committerSam James <sam@gentoo.org>2021-10-14 08:56:03 +0100
commitd31aeb16483ebad21a58dffbb73dede5982f21f5 (patch)
tree83f2c7d5daba04bb6d55a5dc4190493b1efd2ce6 /dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r2.ebuild
parentdev-util/patdiff: fix dependencies (diff)
downloadgentoo-d31aeb16483ebad21a58dffbb73dede5982f21f5.tar.gz
gentoo-d31aeb16483ebad21a58dffbb73dede5982f21f5.tar.bz2
gentoo-d31aeb16483ebad21a58dffbb73dede5982f21f5.zip
dev-ml/pcre-ocaml: fix dependencies
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r2.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r2.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r2.ebuild
new file mode 100644
index 000000000000..7bc4861b3f59
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+S="${WORKDIR}/pcre-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples +ocamlopt"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ppc x86"
+
+BDEPEND="dev-ml/dune-configurator"
+RDEPEND=">=dev-libs/libpcre-4.5
+ dev-ml/stdio:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune_src_install pcre
+
+ if use examples ; then
+ dodoc -r examples
+ fi
+}