summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocaml-gettext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocaml-gettext')
-rw-r--r--dev-ml/ocaml-gettext/Manifest2
-rw-r--r--dev-ml/ocaml-gettext/metadata.xml5
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.3.4.ebuild47
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.3.5.ebuild48
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext/Manifest b/dev-ml/ocaml-gettext/Manifest
new file mode 100644
index 000000000000..e4ad40498dae
--- /dev/null
+++ b/dev-ml/ocaml-gettext/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-gettext-0.3.4.tar.gz 165292 SHA256 e19214638e8cf078aabda82e7bc4d49a65a557d9c54648a7fd8db6ef84c83302 SHA512 bd51c267c28cb77d0648d9570ef4d75c149c921c75f611229b50f8f6a521997d4fd044f1aa4ffbb2628e1e38c3bee58f113495536a47db2e3ca58e0903a312bc WHIRLPOOL c7a7a33e75837a25fdbeac72610a697fe2819cea8c07b2d3b570e90be6a187bc9037d10c56e182a0dd9810c1d7ba04e4f002a8196b87c5c6ee760ac3b6e991a6
+DIST ocaml-gettext-0.3.5.tar.gz 165238 SHA256 d19484ba7e14d078c85da66cba1eb28ed0cdc92c84db45e6dfb8f7e40f2cc268 SHA512 a60d51c09dad3076415ef24a9bb3121f84ad649d7a9fa1b9a7da719dd385e4ed7cd9ffbabefbade7ea0daf7b0a5a5eb71b1d0ed21b369914b49f66d0d918c446 WHIRLPOOL b638ecfe765e673408ced9e4ee0467029b7a7dbf0dfff826c45471b0cea2c26765db9b833d261be325abf5579e90ab0f669fac2a1cd7682e26d49a2fc277e5f0
diff --git a/dev-ml/ocaml-gettext/metadata.xml b/dev-ml/ocaml-gettext/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ocaml-gettext/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.3.4.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.4.ebuild
new file mode 100644
index 000000000000..59567a216385
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-gettext"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/676/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/ocaml-3.12.1:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ >=dev-ml/camomile-0.8.3:=
+ sys-devel/gettext
+ "
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
+ test? ( dev-ml/ounit )"
+
+src_configure() {
+ econf \
+ --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
+ $(use_enable doc) \
+ $(use_enable test)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake -j1 DESTDIR="${D}" \
+ BINDIR="${ED}/usr/bin" \
+ PODIR="${ED}/usr/share/locale/" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ MANDIR="${ED}/usr/share/man" \
+ install
+ dodoc CHANGELOG README THANKS TODO
+}
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.3.5.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.5.ebuild
new file mode 100644
index 000000000000..bb0e145683bb
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-gettext"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1433/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/ocaml-3.12.1:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ >=dev-ml/camomile-0.8.3:=
+ sys-devel/gettext
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ "
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
+ test? ( dev-ml/ounit )"
+
+src_configure() {
+ econf \
+ --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
+ $(use_enable doc) \
+ $(use_enable test)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake -j1 DESTDIR="${D}" \
+ BINDIR="${ED}/usr/bin" \
+ PODIR="${ED}/usr/share/locale/" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ MANDIR="${ED}/usr/share/man" \
+ install
+ dodoc CHANGELOG README THANKS TODO
+}