summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-27 10:44:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-27 10:44:37 +0100
commit27f87a84154995471e086d5a88fb94f90278f164 (patch)
tree62ff82c4f50c6f221787ae39a60c57fb6a0d6d08 /dev-ml/ocaml-ctypes
parentmedia-libs/game-music-emu: Bump to 0.6.1, bug #603092 (diff)
downloadgentoo-27f87a84154995471e086d5a88fb94f90278f164.tar.gz
gentoo-27f87a84154995471e086d5a88fb94f90278f164.tar.bz2
gentoo-27f87a84154995471e086d5a88fb94f90278f164.zip
dev-ml/ocaml-ctypes: Add missing lwt deps for tests
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..34b6fa315adf
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit dev-ml/lwt )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}