summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-27 18:26:55 +0100
committerSam James <sam@gentoo.org>2021-07-27 18:30:20 +0100
commit02f297ef6ce85d6d9896e1dedde33cf13fb54d1c (patch)
tree3b0cc99027a020ea8352216a9f96ebbc644043e1 /dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild
parentapp-backup/borgmatic: get rid of vim dependency in tests (diff)
downloadgentoo-02f297ef6ce85d6d9896e1dedde33cf13fb54d1c.tar.gz
gentoo-02f297ef6ce85d6d9896e1dedde33cf13fb54d1c.tar.bz2
gentoo-02f297ef6ce85d6d9896e1dedde33cf13fb54d1c.zip
dev-ml/ocaml-ctypes: unrestrict libffi subslot
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild
new file mode 100644
index 000000000000..a473cbada2f3
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm ~arm64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}