summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 15:18:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 15:25:27 +0200
commitc0509acd103d992bca60f80b05e20c8b980ea516 (patch)
tree26c97c80c13fc91ce2d83d75d54e304995eab9db /dev-ml/ocaml-compiler-libs
parentx11-wm/mutter: amd64 stable wrt bug #611134 (diff)
downloadgentoo-c0509acd103d992bca60f80b05e20c8b980ea516.tar.gz
gentoo-c0509acd103d992bca60f80b05e20c8b980ea516.tar.bz2
gentoo-c0509acd103d992bca60f80b05e20c8b980ea516.zip
dev-ml/ocaml-compiler-libs: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-compiler-libs')
-rw-r--r--dev-ml/ocaml-compiler-libs/Manifest1
-rw-r--r--dev-ml/ocaml-compiler-libs/metadata.xml8
-rw-r--r--dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild28
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-compiler-libs/Manifest b/dev-ml/ocaml-compiler-libs/Manifest
new file mode 100644
index 000000000000..0e0e6c6daf0a
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/Manifest
@@ -0,0 +1 @@
+DIST ocaml-compiler-libs-0.9.0.tar.gz 6937 SHA256 74944fba8a66966aa73366d030aa01b631856b73e26bbb0aa81ffa9e774ceed8 SHA512 ee0751bcfb9cb75d272f7af4f7da184c0a8e348384a2481da9dea0245a4133de908a23d0a324e0353397a4f0c5bfd71d40a6a46dbd8e4acea922bad7cdc5ef64 WHIRLPOOL 3c051095613ed1faede5f77e73a289cc17091d6d7455ed96491a3c4f25ceda1057691ebbee24b390e401b9ecb5344e9edf135e4906f648a6aa27cd9e38e1cd2e
diff --git a/dev-ml/ocaml-compiler-libs/metadata.xml b/dev-ml/ocaml-compiler-libs/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
new file mode 100644
index 000000000000..a7eb91fb1ad3
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Repackage the OCaml compiler libraries so they do not expose everything at toplevel"
+HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
+SRC_URI="https://github.com/janestreet/ocaml-compiler-libs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}