summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-01-11 21:23:34 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-01-11 21:23:34 +0100
commit7680f7e7d7c873b3d2cc15edf31591a1d5e12ec9 (patch)
tree813c0dcdf7c8f65b2be261fc7546689ad23685a3 /dev-ml/markup
parentx11-libs/libva-intel-media-driver: fixed tests (diff)
downloadgentoo-7680f7e7d7c873b3d2cc15edf31591a1d5e12ec9.tar.gz
gentoo-7680f7e7d7c873b3d2cc15edf31591a1d5e12ec9.tar.bz2
gentoo-7680f7e7d7c873b3d2cc15edf31591a1d5e12ec9.zip
dev-ml/markup: fix test and use dune eclass
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/markup')
-rw-r--r--dev-ml/markup/markup-1.0.0.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/dev-ml/markup/markup-1.0.0.ebuild b/dev-ml/markup/markup-1.0.0.ebuild
index be349d21561b..011aaf40c7e4 100644
--- a/dev-ml/markup/markup-1.0.0.ebuild
+++ b/dev-ml/markup/markup-1.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit opam multiprocessing
+inherit dune
DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
HOMEPAGE="https://github.com/aantron/markup.ml"
@@ -12,19 +12,7 @@ SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-lang/ocaml:="
-BDEPEND=">=dev-ml/dune-2.7
- dev-lang/ocaml"
-DEPEND="${RDEPEND}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
S="${WORKDIR}/${PN}.ml-${PV}"
-
-src_compile() {
- dune build -p "${PN}" -j $(makeopts_jobs) @install || die
-}
-
-src_test() {
- dune runtest -p "${PN}" -j $(makeopts_jobs) || die
-}