summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-10 15:20:11 +0000
committerSam James <sam@gentoo.org>2021-02-10 15:20:45 +0000
commit5415cba637fe14230e3ebc5353fcf3becd0d63f5 (patch)
treefc4cd1859d832ca6de84bb2b067b150d749059f5 /dev-ml/fmt
parentdev-ml/dose3: add upper bound on OCaml for 5.0.1-r1 (diff)
downloadgentoo-5415cba637fe14230e3ebc5353fcf3becd0d63f5.tar.gz
gentoo-5415cba637fe14230e3ebc5353fcf3becd0d63f5.tar.bz2
gentoo-5415cba637fe14230e3ebc5353fcf3becd0d63f5.zip
dev-ml/fmt: bump to 0.8.9
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/fmt')
-rw-r--r--dev-ml/fmt/Manifest1
-rw-r--r--dev-ml/fmt/fmt-0.8.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
index d92968186fd6..6bade5578e9b 100644
--- a/dev-ml/fmt/Manifest
+++ b/dev-ml/fmt/Manifest
@@ -1 +1,2 @@
DIST fmt-0.8.4.tbz 14079 BLAKE2B c4b6fc35a27734e8d878ef1abfa900b659d4acafc20757b0413aec1404378aed6e57c6a1a0e5c7dbda7e60fdd911d38fa1fecc76d670299ddf6ed14930fbcc28 SHA512 d17407f15447172ad444fa288b9a16962b0e4829cb73f62004b0f8dad2bec60a7911ad11fd05545d61d7fdb88099e53694548c73368399ba183c53383e1dfd31
+DIST fmt-0.8.9.tbz 21469 BLAKE2B 4cddf626118c9bdea435f9db4e6a3c0b92b49b2c07d1b0f708ae7b82963453be666ad49df196d98b466236509d3fa5a519e191da6b2385a308d1019f1583f0b5 SHA512 19b97caf5d2dbe86cd75bec478707b8f4e4b899b2a11ce04790dc5acb5c9ed6ea98047de52ee50c6480231a16307af2541eabaa94d18d7d008f7a67496f5f626
diff --git a/dev-ml/fmt/fmt-0.8.9.ebuild b/dev-ml/fmt/fmt-0.8.9.ebuild
new file mode 100644
index 000000000000..5dc34df3f2c5
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.8.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="https://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="https://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+ dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}