summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-08 15:31:28 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-08 15:33:09 +0200
commit3928a494c08756468dd48f2fe8984751a50ad1c1 (patch)
treead27d58d5c8f8182c4dccb63088af43210712f52 /dev-lisp
parentcommon-lisp-common.eclass: Drop uneeded eclass (diff)
downloadgentoo-3928a494c08756468dd48f2fe8984751a50ad1c1.tar.gz
gentoo-3928a494c08756468dd48f2fe8984751a50ad1c1.tar.bz2
gentoo-3928a494c08756468dd48f2fe8984751a50ad1c1.zip
dev-lisp/common-lisp-controller: Drop last rited package
Closes: https://bugs.gentoo.org/646742
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/common-lisp-controller/Manifest2
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild92
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild96
-rw-r--r--dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp3
-rw-r--r--dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp3
-rw-r--r--dev-lisp/common-lisp-controller/files/README.Gentoo27
-rw-r--r--dev-lisp/common-lisp-controller/metadata.xml14
7 files changed, 0 insertions, 237 deletions
diff --git a/dev-lisp/common-lisp-controller/Manifest b/dev-lisp/common-lisp-controller/Manifest
deleted file mode 100644
index 7729f647d923..000000000000
--- a/dev-lisp/common-lisp-controller/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST common-lisp-controller_4.27.tar.gz 27636 BLAKE2B de8ff4d5f10204b73217961d69afaa25258a429d0079767dc8b68b99b4b9dfc52f3f58dce97835a3f5c89fcb035b50ea843ad3cbfd234f9ebb3626bc70a847b8 SHA512 afba310bf525fb40f98a6bd67747647d105080667a3ebef883e19ffc60186bdfc7b937c2efe7535e3daa08503d8079d69453264fe8124f1b9a4a55e6303fe1b3
-DIST common-lisp-controller_5.13.tar.gz 30846 BLAKE2B db621ea6dab8aadcd7ec6eeb58e600e55d8bd1a31be6dc950fe3bafa48d24777d0a1dba3571adfb852946b01ce61dcff26f034aee4d89b994fbec3012df3d803 SHA512 11a6e2b7a3ca6846c8b88ee3808ae4e01c269dce8eb4293e57bf061a6c74786fe8bdff0f11c3db5c8ac60e3ba7a1e74222f9ab1418da114b6ece2fa6f23464e2
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild
deleted file mode 100644
index 1a7c3508f040..000000000000
--- a/dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils
-
-DESCRIPTION="Common Lisp Controller"
-HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller"
-SRC_URI="mirror://gentoo/common-lisp-controller_${PV}.tar.gz"
-
-LICENSE="LLGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="|| ( >=sys-apps/coreutils-8.15 app-misc/realpath )
- >=dev-lisp/asdf-1.84
- dev-lang/perl"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}/man"
- ln -s clc-{,un}register-user-package.1
- for i in unregister-common-lisp-implementation {,un}register-common-lisp-source; do
- ln -s register-common-lisp-implementation.8 ${i}.8
- done
-}
-
-src_install() {
- dobin clc-register-user-package
- dobin clc-unregister-user-package
- dosbin register-common-lisp-implementation
- dosbin register-common-lisp-source
- dosbin unregister-common-lisp-implementation
- dosbin unregister-common-lisp-source
- insinto /usr/share/common-lisp/source/common-lisp-controller
- doins common-lisp-controller.lisp
- doins post-sysdef-install.lisp
- doman man/*.[18]
- insinto /etc
- doins "${FILESDIR}/${PV}/lisp-config.lisp"
- dodoc "${FILESDIR}/README.Gentoo"
- dodoc DESIGN.txt
-}
-
-pkg_postinst() {
- test -d /var/cache/common-lisp-controller \
- || mkdir /var/cache/common-lisp-controller
- chmod 1777 /var/cache/common-lisp-controller
-
- # This code from ${S}/debian/postinst
-
- for compiler in /usr/lib/common-lisp/bin/*.sh
- do
- if [ -f "${compiler}" -a -r "${compiler}" -a -x "${compiler}" ] ; then
- i=${compiler##*/}
- i=${i%.sh}
- einfo ">>> Recompiling Common Lisp Controller for $i"
- bash "$compiler" install-clc || true
- einfo ">>> Done rebuilding"
- fi
- done
-
- # This code from ${S}/debian/preinst
-
- # cleanup fasl files:
- ( find /usr/share/common-lisp/source/defsystem \
- /usr/share/common-lisp/source/asdf \
- /usr/share/common-lisp/source/common-lisp-controller -type f -not -name "*.lisp" -print0 \
- | xargs --null rm --force 2> /dev/null ) &>/dev/null
-
- # remove old autobuild files:
-# find /etc/common-lisp -name autobuild -print0 \
-# | xargs -0 rm 2> /dev/null || true
-# find /etc/common-lisp -type d -depth -print0 \
-# | xargs rmdir 2> /dev/null || true
-
- # remove old fals files:
- test -d /usr/lib/common-lisp-controller \
- && rmdir --ignore-fail-on-non-empty /usr/lib/common-lisp-controller
- for compiler in /usr/lib/common-lisp/bin/*.sh ; do
- if [ -f "$compiler" -a -r "$compiler" ] ; then
- i=${compiler##*/}
- i=${i%.sh}
- if [ -d "/usr/lib/common-lisp/${i}" ] ; then
- rm -rf "/usr/lib/common-lisp/${i}"
- fi
- fi
- done
-}
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild
deleted file mode 100644
index 450a227f9929..000000000000
--- a/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="3"
-inherit eutils
-
-DESCRIPTION="Common Lisp Controller"
-HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller"
-SRC_URI="mirror://gentoo/common-lisp-controller_${PV}.tar.gz"
-
-LICENSE="LLGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="|| ( >=sys-apps/coreutils-8.15 app-misc/realpath )
- >=dev-lisp/asdf-1.84
- dev-lang/perl"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}/man"
- ln -s clc-{,un}register-user-package.1
- for i in unregister-common-lisp-implementation {,un}register-common-lisp-source; do
- ln -s register-common-lisp-implementation.8 ${i}.8
- done
-}
-
-src_install() {
- dobin clc-register-user-package
- dobin clc-unregister-user-package
- dosbin register-common-lisp-implementation
- dosbin register-common-lisp-source
- dosbin unregister-common-lisp-implementation
- dosbin unregister-common-lisp-source
-
- dosbin clc-update-customized-images
- keepdir /etc/common-lisp/images
-
- insinto /usr/share/common-lisp/source/common-lisp-controller
- doins common-lisp-controller.lisp post-sysdef-install.lisp
- doman man/*.[138]
- insinto /etc
- doins "${FILESDIR}/${PV}/lisp-config.lisp"
- dodoc "${FILESDIR}/README.Gentoo"
- dodoc DESIGN.txt debian/changelog
-}
-
-pkg_postinst() {
- test -d /var/cache/common-lisp-controller \
- || mkdir /var/cache/common-lisp-controller
- chmod 1777 /var/cache/common-lisp-controller
-
- # This code from ${S}/debian/postinst
-
- for compiler in /usr/lib/common-lisp/bin/*.sh
- do
- if [ -f "${compiler}" -a -r "${compiler}" -a -x "${compiler}" ] ; then
- i=${compiler##*/}
- i=${i%.sh}
- einfo ">>> Recompiling Common Lisp Controller for $i"
- bash "$compiler" install-clc || true
- einfo ">>> Done rebuilding"
- fi
- done
-
- # This code from ${S}/debian/preinst
-
- # cleanup fasl files:
- ( find /usr/share/common-lisp/source/defsystem \
- /usr/share/common-lisp/source/asdf \
- /usr/share/common-lisp/source/common-lisp-controller -type f -not -name "*.lisp" -print0 \
- | xargs --null rm --force 2> /dev/null ) &>/dev/null
-
- # remove old autobuild files:
-# find /etc/common-lisp -name autobuild -print0 \
-# | xargs -0 rm 2> /dev/null || true
-# find /etc/common-lisp -type d -depth -print0 \
-# | xargs rmdir 2> /dev/null || true
-
- # remove old fals files:
- test -d /usr/lib/common-lisp-controller \
- && rmdir --ignore-fail-on-non-empty /usr/lib/common-lisp-controller
- for compiler in /usr/lib/common-lisp/bin/*.sh ; do
- if [ -f "$compiler" -a -r "$compiler" ] ; then
- i=${compiler##*/}
- i=${i%.sh}
- if [ -d "/usr/lib/common-lisp/${i}" ] ; then
- rm -rf "/usr/lib/common-lisp/${i}"
- fi
- fi
- done
-}
diff --git a/dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp b/dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp
deleted file mode 100644
index a6d36ce22005..000000000000
--- a/dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp
+++ /dev/null
@@ -1,3 +0,0 @@
-
-(in-package common-lisp-user)
-
diff --git a/dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp b/dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp
deleted file mode 100644
index a6d36ce22005..000000000000
--- a/dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp
+++ /dev/null
@@ -1,3 +0,0 @@
-
-(in-package common-lisp-user)
-
diff --git a/dev-lisp/common-lisp-controller/files/README.Gentoo b/dev-lisp/common-lisp-controller/files/README.Gentoo
deleted file mode 100644
index adaa56315a4f..000000000000
--- a/dev-lisp/common-lisp-controller/files/README.Gentoo
+++ /dev/null
@@ -1,27 +0,0 @@
- -*-outline-*-
-
-* Common Lisp Controller 4.x and 5.x
-
-With version 4.x and 5.x of the Debian Common Lisp Controller, the
-design of the controller was simplified so that source was compiled
-into /var/cache/, per user, on demand (ie. when you evaluate (require
-:foo) at the REPL).
-
-* Common Lisp Controller 3.x
-
-** IMPORTANT
-
-The Common Lisp Controller (CLC) in Gentoo GNU/Linux is a modified
-version of the original CLC sources from the Debian Project. Do not
-send bug reports to the Debian Project -- always send bug reports to
-http://bugs.gentoo.org.
-
-** NOTES
-
-If you are used to the CLC in Debian, please note that the Gentoo CLC
-does not require an Internet super-server such as inetd or xinetd in
-order to function. The original CLC implementation's clc-send-command
-has been replaced with a shell script which implements the same
-interface, but bypasses clc-build-daemon entirely.
-
--- Matthew Kennedy <mkennedy@gentoo.org>
diff --git a/dev-lisp/common-lisp-controller/metadata.xml b/dev-lisp/common-lisp-controller/metadata.xml
deleted file mode 100644
index 9b129ff98209..000000000000
--- a/dev-lisp/common-lisp-controller/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>common-lisp@gentoo.org</email>
- <name>Gentoo Common Lisp Project</name>
-</maintainer>
-<longdescription>
-The Common Lisp Controller was originally used in the Debian project. The Common
-Lisp Contoller lets you install and manage common lisp sources and compilers.
-It creates a user-specific cache of compiled objects. When a library or an
-implementation is upgraded all compiled objects in the cache are flushed.
-</longdescription>
-</pkgmetadata>