summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-15 09:45:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-15 18:33:38 +0200
commit5f5fee3559f1963e259fc1a136c74da863e57631 (patch)
treeff1184a58ce25e21ae938adafdb15d92431334a7 /dev-libs
parentdev-util/ignition-cmake: drop multilib here (diff)
downloadgentoo-5f5fee3559f1963e259fc1a136c74da863e57631.tar.gz
gentoo-5f5fee3559f1963e259fc1a136c74da863e57631.tar.bz2
gentoo-5f5fee3559f1963e259fc1a136c74da863e57631.zip
dev-libs/sdformat: bump to 9.2.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/sdformat/Manifest1
-rw-r--r--dev-libs/sdformat/sdformat-9.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/sdformat/Manifest b/dev-libs/sdformat/Manifest
index ee2af9764e53..9249b8c9d7d8 100644
--- a/dev-libs/sdformat/Manifest
+++ b/dev-libs/sdformat/Manifest
@@ -1 +1,2 @@
DIST sdformat-6.2.0.tar.bz2 466373 BLAKE2B 67bbe429cbd9871493c29379563f0704b8a050eb8e80645d92a6dea47321e0853bfd4b8442893792a47d743d7b701add21b45fcb7dfd21b2747d43f3f4d19f68 SHA512 e81f0f73e628155ef929c6d7930611f02009a8a217a043e127506c1310ae892b846a8080906feb0932108e9cfa280f473573a5af5096b55b66619b2ac794b0d5
+DIST sdformat-9.2.0.tar.bz2 644484 BLAKE2B 2f6382414bd7d47bfafb66c8352e5a90cd236bdfcfc7c3119eab154b8d0bb5fddf2127b16e222bb90326dbf91f95b111643eede17ebe38f27bb164cf31d7f263 SHA512 bc9422207f56d7fd5f53249f856be5fe00f078e168d7e93ab10f5544e4963888cb7c0a1b1f449739e2490b0d5aad3c5a72d8408333dd6ae550b5d66f6bcde42a
diff --git a/dev-libs/sdformat/sdformat-9.2.0.ebuild b/dev-libs/sdformat/sdformat-9.2.0.ebuild
new file mode 100644
index 000000000000..2e44e5b271f2
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-9.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/sdformat/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# subslot = libsdformat major
+SLOT="0/9"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/urdfdom-1:=
+ dev-libs/tinyxml
+ dev-libs/boost:=
+ sci-libs/ignition-math:6=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/ruby:*
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ local mycmakeargs=(
+ "-DUSE_INTERNAL_URDF=OFF"
+ "-DUSE_EXTERNAL_TINYXML=ON"
+ )
+ cmake-utils_src_configure
+}