summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-07-21 18:53:45 -0700
committerAnthony G. Basile <blueness@gentoo.org>2022-07-22 08:42:41 -0400
commit6a4b73aff0b585dac26d161e8a0a5a906cf3c00f (patch)
tree428518d2e1cf06fbe991c98ce7840268fcd7b01c /dev-libs/xapian-bindings
parentdev-util/maturin: also add ppc to rustls exclude (diff)
downloadgentoo-6a4b73aff0b585dac26d161e8a0a5a906cf3c00f.tar.gz
gentoo-6a4b73aff0b585dac26d161e8a0a5a906cf3c00f.tar.bz2
gentoo-6a4b73aff0b585dac26d161e8a0a5a906cf3c00f.zip
dev-libs/xapian-bindings: Fix the build with slibtool
Bug: https://bugs.gentoo.org/793428 Upstream-PR: https://github.com/xapian/xapian/pull/322 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-libs/xapian-bindings')
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-1.4.20-slibtool.patch133
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.4.20-r1.ebuild352
2 files changed, 485 insertions, 0 deletions
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-1.4.20-slibtool.patch b/dev-libs/xapian-bindings/files/xapian-bindings-1.4.20-slibtool.patch
new file mode 100644
index 000000000000..d73f8bcb19b9
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-1.4.20-slibtool.patch
@@ -0,0 +1,133 @@
+Upstream-PR: https://github.com/xapian/xapian/pull/322
+
+From c513b0d31d2df31eb57ccbe08bbe46821863557d Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Wed, 20 Jul 2022 13:37:20 -0700
+Subject: [PATCH] xapian-bindings: Fix the build with slibtool
+
+With slibtool the --config argument works differently than in GNU
+libtool which results in 'auto/Xapian/Xapian$(PERL_SO)' failing to be
+created. This can be worked around by using libtool --mode=install where
+slibtool can copy the module to the intended location.
+
+However GNU libtool still requires using --config otherwise it fails
+during --mode=install with the following error.
+
+ /bin/bash ../libtool --mode=install cp Xapian.la /home/runner/work/xapian/xapian/perl/auto/Xapian/Xapian.la
+ libtool: error: error: cannot install 'Xapian.la' to a directory not ending in /usr/local/lib/x86_64-linux-gnu/perl/5.26.1/auto/Xapian
+
+gentoo issue: https://bugs.gentoo.org/793428
+---
+ java/run-java-test | 21 +++++++++++++++++----
+ perl/Makefile.am | 9 +++++++--
+ python3/Makefile.am | 9 +++++++--
+ tcl8/run-tcl-test | 20 +++++++++++++-------
+ 4 files changed, 44 insertions(+), 15 deletions(-)
+
+diff --git a/java/run-java-test b/java/run-java-test
+index d0e97af300e..a838de98492 100755
+--- a/java/run-java-test
++++ b/java/run-java-test
+@@ -1,11 +1,24 @@
+ #!/bin/sh
+ # To run `jdb` instead of `java` set JAVA=jdb
+ # To run under gdb, set JAVA='gdb --args java'
++LIBTOOL="${LIBTOOL-../libtool}"
+ arg=`echo "$1"|sed 's!.*/!!;s!\.class$!!'`
++
++# GNU libtool and slibtool have different and incompatible usage for --config.
++if ${LIBTOOL} --config > libtoolconfig.$$ 2>/dev/null; then
++ . ./libtoolconfig.$$
++else
++ objdir="built/libs"
++ rm -rf "$objdir"
++ mkdir -p "$objdir"
++ ${LIBTOOL} --mode=install cp libxapian_jni.la "$objdir"
++fi
++rm -f libtoolconfig.$$
++
+ # Use libtool's -dlopen option to ensure that libxapian_jni.so (or whatever)
+ # is in the shared library path.
+-${LIBTOOL-../libtool} --config > libtoolconfig.$$
+-. ./libtoolconfig.$$
+-rm -f libtoolconfig.$$
+-${LIBTOOL-../libtool} -dlopen libxapian_jni.la --mode=execute \
++${LIBTOOL} -dlopen libxapian_jni.la --mode=execute \
+ $OSX_SIP_HACK_ENV ${JAVA-java} -Djava.library.path="$objdir" -classpath built/xapian.jar${PATHSEP-:}. "$arg"
++rc=$?
++rm -rf built/libs
++exit $rc
+diff --git a/perl/Makefile.am b/perl/Makefile.am
+index 4f2e5e4283d..f71579736e5 100644
+--- a/perl/Makefile.am
++++ b/perl/Makefile.am
+@@ -55,9 +55,14 @@ BUILT_SOURCES = Xapian.pm xapian_wrap.cc \
+
+ auto/Xapian/Xapian$(PERL_SO): Xapian.la
+ @$(MKDIR_P) auto/Xapian
+- $(LIBTOOL) --config > libtoolconfig.tmp
++## GNU libtool and slibtool have different and incompatible usage for --config.
++ if $(LIBTOOL) --config > libtoolconfig.tmp 2>/dev/null; then \
+ ## ksh requires a path on the sourced file.
+- . ./libtoolconfig.tmp; cp "$$objdir/Xapian$(PERL_SO)" auto/Xapian
++ . ./libtoolconfig.tmp; \
++ cp "$$objdir/Xapian$(PERL_SO)" auto/Xapian; \
++ else \
++ $(LIBTOOL) --mode=install cp $< $@; \
++ fi;
+ rm -f libtoolconfig.tmp
+
+ EXTRA_DIST = perl.i except.i extra.i $(TESTS) \
+diff --git a/python3/Makefile.am b/python3/Makefile.am
+index 3c692a9e2d4..9bf01833636 100644
+--- a/python3/Makefile.am
++++ b/python3/Makefile.am
+@@ -88,9 +88,14 @@ xapian/__pycache__/__init__.@PYTHON3_CACHE_OPT1_EXT@: xapian/__init__.py xapian/
+
+ xapian/_xapian$(PYTHON3_EXT_SUFFIX): _xapian.la
+ $(MKDIR_P) xapian
+- $(LIBTOOL) --config > libtoolconfig.tmp
++## GNU libtool and slibtool have different and incompatible usage for --config.
++ if $(LIBTOOL) --config > libtoolconfig.tmp 2>/dev/null; then \
+ ## ksh requires a path on the sourced file.
+- . ./libtoolconfig.tmp; cp $$objdir/_xapian$(PYTHON3_EXT_SUFFIX) xapian
++ . ./libtoolconfig.tmp; \
++ cp $$objdir/_xapian$(PYTHON3_EXT_SUFFIX) xapian; \
++ else \
++ $(LIBTOOL) --mode=install cp $< $@; \
++ fi;
+ rm -f libtoolconfig.tmp
+
+ CLEANFILES = \
+diff --git a/tcl8/run-tcl-test b/tcl8/run-tcl-test
+index 206b5e0e056..71511032024 100755
+--- a/tcl8/run-tcl-test
++++ b/tcl8/run-tcl-test
+@@ -1,14 +1,20 @@
+ #!/bin/sh
+-${LIBTOOL-../libtool} --config > libtoolconfig.$$
+-. ./libtoolconfig.$$
+-rm -f libtoolconfig.$$
++tclshlibext=`echo 'puts [info sharedlibextension]'|${TCLSH-tclsh}`
++rm -f xapian$tclshlibext
++
++LIBTOOL="${LIBTOOL-../libtool}"
+ module=yes
+-eval shlibext=$shrext_cmds
+
+-tclshlibext=`echo 'puts [info sharedlibextension]'|${TCLSH-tclsh}`
++# GNU libtool and slibtool have different and incompatible usage for --config.
++if ${LIBTOOL} --config > libtoolconfig.$$ 2>/dev/null; then
++ . ./libtoolconfig.$$
++ eval shlibext=$shrext_cmds
++ ln -s $objdir/xapian$shlibext xapian$tclshlibext
++else
++ ${LIBTOOL} --mode=install cp xapian.la ./xapian$tclshlibext
++fi
++rm -f libtoolconfig.$$
+
+-rm -f xapian$tclshlibext
+-ln -s $objdir/xapian$shlibext xapian$tclshlibext
+ $OSX_SIP_HACK_ENV ${TCLSH-tclsh} ${srcdir-.}/runtest.tcl ${srcdir-.}/smoketest.tcl
+ rc=$?
+ rm -f xapian$tclshlibext
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.4.20-r1.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.4.20-r1.ebuild
new file mode 100644
index 000000000000..adaa8d9ff860
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.4.20-r1.ebuild
@@ -0,0 +1,352 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1,3,4} luajit )
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_REQ_USE="threads(+)"
+
+USE_PHP="php7-4 php8-0"
+
+PHP_EXT_NAME="xapian"
+PHP_EXT_INI="yes"
+PHP_EXT_OPTIONAL_USE="php"
+
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_OPTIONAL="yes"
+
+inherit autotools java-pkg-opt-2 lua mono-env multibuild php-ext-source-r3 python-r1 ruby-ng
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="https://www.xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java lua mono perl php python ruby tcl"
+REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ruby? ( || ( $(ruby_get_use_targets) ) )"
+
+COMMONDEPEND=">=dev-libs/xapian-1.4.20
+ lua? ( ${LUA_DEPS} )
+ perl? ( dev-lang/perl:= )
+ php? ( dev-lang/php:=[-threads] )
+ python? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ ruby? ( $(ruby_implementations_depend) )
+ tcl? ( dev-lang/tcl:= )
+ mono? ( dev-lang/mono )"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.8:* )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.8:* )"
+
+S="${WORKDIR}/${P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-slibtool.patch # 793428
+)
+
+has_basic_bindings() {
+ # Update this list if new bindings are added that are not built
+ # multiple times for multiple versions like lua, php, python and ruby are
+ return $(use mono || use java || use perl || use tcl)
+}
+
+php_copy_sources() {
+ local MULTIBUILD_VARIANTS=($(php_get_slots))
+ multibuild_copy_sources
+}
+
+php_foreach_impl() {
+ local MULTIBUILD_VARIANTS=($(php_get_slots))
+ multibuild_foreach_variant "$@"
+}
+
+ruby_copy_sources() {
+ local MULTIBUILD_VARIANTS=($(ruby_get_use_implementations))
+ multibuild_copy_sources
+}
+
+ruby_foreach_impl() {
+ local MULTIBUILD_VARIANTS=($(ruby_get_use_implementations))
+ multibuild_foreach_variant "$@"
+}
+
+pkg_setup() {
+ use mono && mono-env_pkg_setup
+ use java && java-pkg-opt-2_pkg_setup
+}
+
+src_unpack() {
+ default
+
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ # Unfortunately required for php-ext-source-r3_createinifiles().
+ mkdir "${WORKDIR}/${php_slot}"
+ done
+ fi
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ use java && java-pkg-opt-2_src_prepare
+
+ # https://trac.xapian.org/ticket/702
+ export XAPIAN_CONFIG="/usr/bin/xapian-config"
+
+ if use lua; then
+ lua_copy_sources
+ fi
+
+ if use php; then
+ php_copy_sources
+ fi
+
+ if use python; then
+ python_copy_sources
+ fi
+
+ if use ruby; then
+ ruby_copy_sources
+ fi
+}
+
+src_configure() {
+ # Needed to get e.g. test failure details
+ MAKEOPTS+=" VERBOSE=1"
+
+ if has_basic_bindings ; then
+ local conf=(
+ --disable-documentation
+ $(use_with mono csharp)
+ $(use_with java)
+ $(use_with perl)
+ $(use_with tcl)
+ --without-lua
+ --without-php
+ --without-php7
+ --without-python
+ --without-python3
+ --without-ruby
+ )
+
+ if use java; then
+ local -x CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ fi
+
+ if use perl; then
+ local -x PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
+ local -x PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
+ fi
+
+ econf "${conf[@]}"
+ fi
+
+ lua_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-csharp
+ --without-java
+ --without-perl
+ --without-tcl
+ --without-php
+ --without-php7
+ --without-python
+ --without-python3
+ --without-ruby
+ --with-lua
+ )
+
+ local -x LUA_INC="$(lua_get_include_dir)"
+ local -x LUA_LIB="$(lua_get_cmod_dir)"
+
+ econf "${myconf[@]}"
+
+ }
+
+ if use lua; then
+ lua_foreach_impl run_in_build_dir lua_configure
+ fi
+
+ php_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-python
+ --without-python3
+ --without-ruby
+ --without-tcl
+ )
+ if [[ ${MULTIBUILD_VARIANT} == php5.* ]]; then
+ myconf+=(
+ --with-php
+ --without-php7
+ )
+ local -x PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${MULTIBUILD_VARIANT/-/.}/bin/php-config"
+ elif [[ ${MULTIBUILD_VARIANT} == php7.* ]]; then
+ myconf+=(
+ --without-php
+ --with-php7
+ )
+ local -x PHP_CONFIG7="${EPREFIX}/usr/$(get_libdir)/${MULTIBUILD_VARIANT/-/.}/bin/php-config"
+ fi
+
+ econf "${myconf[@]}"
+ }
+
+ if use php; then
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/mib_indexes
+
+ php_foreach_impl run_in_build_dir php_configure
+ fi
+
+ python_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-php
+ --without-php7
+ --without-ruby
+ --without-tcl
+ --with-python3
+ )
+
+ # Avoid sandbox failures when compiling modules
+ addpredict "$(python_get_sitedir)"
+
+ econf "${myconf[@]}"
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+
+ ruby_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-php
+ --without-php7
+ --without-python
+ --without-python3
+ --with-ruby
+ --without-tcl
+ )
+ local -x RUBY="${EPREFIX}/usr/bin/${MULTIBUILD_VARIANT}"
+
+ econf "${myconf[@]}"
+ }
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir ruby_configure
+ fi
+}
+
+src_compile() {
+ if has_basic_bindings ; then
+ default
+ fi
+
+ if use lua; then
+ lua_foreach_impl run_in_build_dir emake
+ fi
+
+ if use php; then
+ php_foreach_impl run_in_build_dir emake
+ fi
+
+ if use python; then
+ unset PYTHONDONTWRITEBYTECODE
+ python_foreach_impl run_in_build_dir emake
+ fi
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir emake
+ fi
+}
+
+src_test() {
+ if has_basic_bindings ; then
+ default
+ fi
+
+ if use lua; then
+ lua_foreach_impl run_in_build_dir emake check
+ fi
+
+ if use php; then
+ php_foreach_impl run_in_build_dir emake check
+ fi
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake check
+ fi
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir emake check
+ fi
+}
+
+src_install() {
+ if has_basic_bindings ; then
+ emake DESTDIR="${D}" install
+ fi
+
+ if use java; then
+ java-pkg_dojar java/built/xapian.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso java/.libs/libxapian_jni.so
+ rm -rf "${ED}/var" || die "could not remove java cruft!"
+ fi
+
+ if use lua; then
+ lua_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ fi
+
+ if use php; then
+ php_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ php-ext-source-r3_createinifiles
+ # php-ext-source-r3_createinifiles() changes current directory.
+ cd "${S}"
+ fi
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+ fi
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ fi
+
+ # For some USE combinations this directory is not created
+ if [[ -d "${ED}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${ED}/usr/share/doc/xapian-bindings" "${ED}/usr/share/doc/${PF}" || die
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README
+}