summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-03 18:27:30 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-03 18:30:19 -0400
commit29a5c865cbc341288add2c8d6e3080e5b1ec4369 (patch)
treeed00002d23ed29f84988842e94816108f5b1f062 /dev-libs/wayland
parentdev-util/wayland-scanner: Version bump to 1.21.0 (diff)
downloadgentoo-29a5c865cbc341288add2c8d6e3080e5b1ec4369.tar.gz
gentoo-29a5c865cbc341288add2c8d6e3080e5b1ec4369.tar.bz2
gentoo-29a5c865cbc341288add2c8d6e3080e5b1ec4369.zip
dev-libs/wayland: Update SRC_URI
Also use EAPI=8 and drop unnecessary dependencies on expat and libxml2. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index 5a701656ff6d..bbe4c3904bca 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
inherit git-r3
else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
inherit meson-multilib
@@ -30,8 +30,6 @@ BDEPEND="
)
"
DEPEND="
- >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:=
>=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
"
RDEPEND="${DEPEND}"