summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/udis86/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/udis86/files')
-rw-r--r--dev-libs/udis86/files/udis86-1.7-yasm.patch35
-rw-r--r--dev-libs/udis86/files/udis86-1.7.2-docdir.patch18
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/udis86/files/udis86-1.7-yasm.patch b/dev-libs/udis86/files/udis86-1.7-yasm.patch
new file mode 100644
index 000000000000..3d3eecdf8283
--- /dev/null
+++ b/dev-libs/udis86/files/udis86-1.7-yasm.patch
@@ -0,0 +1,35 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,9 @@
+ AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
+
++AC_PATH_PROG([YASM], yasm,)
++AC_SUBST(YASM)
++
+ # If this is a gnu compiler, pass -Wall
+ if test "$ac_cv_c_compiler_gnu" = "yes"; then
+ CFLAGS="$CFLAGS -Wall"
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -10,7 +10,7 @@
+ ovrrun_LDADD = ../libudis86/libudis86.la
+ ovrrun_CFLAGS = -I$(top_srcdir)/libudis86 -I$(top_srcdir)
+
+-YASM = yasm
++YASM = @YASM@
+
+ dist_check_DATA = test16.asm test32.asm test64.asm testjmp.asm testobscure.asm \
+ testjmp.ref testobscure.ref randtest.raw randtest16.ref \
+@@ -18,7 +18,10 @@
+
+ check-local: tests
+
+-tests: test16 test32 test64 testjmp bufovrrun randraw
++yasm_tests: test16 test32 test64 testjmp
++no_yasm_tests: bufovrrun randraw
++
++tests: $(if $(YASM), yasm_tests) no_yasm_tests
+
+ test16: gen
+ $(YASM) -f bin -o test16.bin $(top_srcdir)/tests/test16.asm
diff --git a/dev-libs/udis86/files/udis86-1.7.2-docdir.patch b/dev-libs/udis86/files/udis86-1.7.2-docdir.patch
new file mode 100644
index 000000000000..3afa72585bd4
--- /dev/null
+++ b/dev-libs/udis86/files/udis86-1.7.2-docdir.patch
@@ -0,0 +1,18 @@
+diff -ur a/docs/manual/Makefile.am b/docs/manual/Makefile.am
+--- a/docs/manual/Makefile.am 2013-09-02 05:46:56.000000000 +0200
++++ b/docs/manual/Makefile.am 2015-03-05 11:22:03.645828113 +0100
+@@ -1,4 +1,4 @@
+-docdir = ${datadir}/docs/udis86/manual
++docdir = @docdir@/manual
+
+ rst_sources = \
+ index.rst \
+diff -ur a/docs/x86/Makefile.am b/docs/x86/Makefile.am
+--- a/docs/x86/Makefile.am 2013-06-29 21:58:38.000000000 +0200
++++ b/docs/x86/Makefile.am 2015-03-05 11:22:30.477826105 +0100
+@@ -1,4 +1,4 @@
+-docdir = ${datadir}/docs/udis86/x86
++docdir = @docdir@/x86
+ dist_doc_DATA = optable.xml optable.xsl
+
+ MAINTAINERCLEANFILES = Makefile.in