summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-08-11 17:57:07 +0200
committerMatthew Smith <matthew@gentoo.org>2022-08-13 08:58:05 +0100
commit4098a9a30345544cdb17c1567f5e4e4ae021276d (patch)
tree197ae516f53025563593442389434f07e695e989 /dev-libs/tllist/tllist-1.1.0.ebuild
parentwww-client/vivaldi: Drop old 5.3.2679.70 (diff)
downloadgentoo-4098a9a30345544cdb17c1567f5e4e4ae021276d.tar.gz
gentoo-4098a9a30345544cdb17c1567f5e4e4ae021276d.tar.bz2
gentoo-4098a9a30345544cdb17c1567f5e4e4ae021276d.zip
dev-libs/tllist: add 1.1.0
Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-libs/tllist/tllist-1.1.0.ebuild')
-rw-r--r--dev-libs/tllist/tllist-1.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/tllist/tllist-1.1.0.ebuild b/dev-libs/tllist/tllist-1.1.0.ebuild
new file mode 100644
index 000000000000..5a9ffb46cadd
--- /dev/null
+++ b/dev-libs/tllist/tllist-1.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Header-only implementation of a typed linked list in C"
+HOMEPAGE="https://codeberg.org/dnkl/tllist"
+SRC_URI="https://codeberg.org/dnkl/tllist/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+
+src_install() {
+ meson_src_install
+
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+}