summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-03-01 10:54:09 +0800
committerSam James <sam@gentoo.org>2023-03-07 07:56:59 +0000
commit82a2720349d070fa86090fd9434bcfae75260a68 (patch)
tree463770ac0ac5e59a78bb69af97d5ddd547e66d63 /dev-libs/rocm-comgr
parentdev-libs/zziplib: add python 3.11 to PYTHON_COMPAT (diff)
downloadgentoo-82a2720349d070fa86090fd9434bcfae75260a68.tar.gz
gentoo-82a2720349d070fa86090fd9434bcfae75260a68.tar.bz2
gentoo-82a2720349d070fa86090fd9434bcfae75260a68.zip
dev-libs/rocm-comgr: Fix comgr and mesa LLVM option collision
>=dev-libs/rocm-comgr-5.3 and <=9999 needs backport a patch from upstream to avoid register -h command line option, which resolves conflicts with media-libs/mesa. Benefits media-gfx/blender. Bug: https://bugs.gentoo.org/851702 Reference: https://github.com/gentoo/gentoo/pull/27552 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29866 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-comgr')
-rw-r--r--dev-libs/rocm-comgr/files/rocm-comgr-5.3.3-remove-h-option.patch43
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-5.3.3-r2.ebuild (renamed from dev-libs/rocm-comgr/rocm-comgr-5.3.3-r1.ebuild)1
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-5.4.3-r1.ebuild (renamed from dev-libs/rocm-comgr/rocm-comgr-5.4.3.ebuild)1
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/rocm-comgr/files/rocm-comgr-5.3.3-remove-h-option.patch b/dev-libs/rocm-comgr/files/rocm-comgr-5.3.3-remove-h-option.patch
new file mode 100644
index 000000000000..1346ba4ef04d
--- /dev/null
+++ b/dev-libs/rocm-comgr/files/rocm-comgr-5.3.3-remove-h-option.patch
@@ -0,0 +1,43 @@
+https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/commit/2d05f9e480cbc591a6b888dfd49d9f7ef1bef25f
+Reference: https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/issues/52
+Reference: https://bugs.gentoo.org/851702#c37
+This unblocks building blender with HIP cycles support
+======================================================================
+From 2d05f9e480cbc591a6b888dfd49d9f7ef1bef25f Mon Sep 17 00:00:00 2001
+From: Jacob Lambert <jacob.lambert@amd.com>
+Date: Thu, 12 Jan 2023 08:45:38 -0800
+Subject: [PATCH] Remove -h option from comgr-objdump
+
+The -h option (short for -headers) is a legal objdump option.
+However registering this as an LLVM option by Comgr prevents other
+LLVM tools or instances from registering a -h option in the same
+process, which is an issue because -h is a common short form for
+-help.
+
+A long term solution will be to libraryize llvm-obj dump, and
+call it in Comgr via an API instead of re-implementation, which
+will eliminate the need for Comgr to register any LLVM options for
+objdump.
+
+Change-Id: Ieb1981aeb1826422647fd301c4827e2bfb370560
+---
+ lib/comgr/src/comgr-objdump.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/lib/comgr/src/comgr-objdump.cpp b/lib/comgr/src/comgr-objdump.cpp
+index 6d20a3c..ead69fe 100644
+--- a/src/comgr-objdump.cpp
++++ b/src/comgr-objdump.cpp
+@@ -175,9 +175,9 @@ cl::opt<bool> SectionHeaders("section-headers",
+ static cl::alias SectionHeadersShort("headers",
+ cl::desc("Alias for --section-headers"),
+ cl::aliasopt(SectionHeaders));
+-static cl::alias SectionHeadersShorter("h",
+- cl::desc("Alias for --section-headers"),
+- cl::aliasopt(SectionHeaders));
++// The following option has been removed to avoid conflicts with
++// other llvm tools/instances also attempting to register a -h option
++// static cl::alias SectionHeadersShorter("h", ...)
+
+ cl::list<std::string>
+ FilterSections("section",
diff --git a/dev-libs/rocm-comgr/rocm-comgr-5.3.3-r1.ebuild b/dev-libs/rocm-comgr/rocm-comgr-5.3.3-r2.ebuild
index f97e82109722..1ed450afa574 100644
--- a/dev-libs/rocm-comgr/rocm-comgr-5.3.3-r1.ebuild
+++ b/dev-libs/rocm-comgr/rocm-comgr-5.3.3-r2.ebuild
@@ -29,6 +29,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.3-HIPIncludePath-not-needed.patch"
"${FILESDIR}/${PN}-5.3.3-fix-tests.patch"
"${FILESDIR}/${PN}-5.3.3-fno-stack-protector.patch"
+ "${FILESDIR}/${PN}-5.3.3-remove-h-option.patch"
)
DESCRIPTION="Radeon Open Compute Code Object Manager"
diff --git a/dev-libs/rocm-comgr/rocm-comgr-5.4.3.ebuild b/dev-libs/rocm-comgr/rocm-comgr-5.4.3-r1.ebuild
index 4f784ee9ee57..f04009a2596a 100644
--- a/dev-libs/rocm-comgr/rocm-comgr-5.4.3.ebuild
+++ b/dev-libs/rocm-comgr/rocm-comgr-5.4.3-r1.ebuild
@@ -28,6 +28,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.3-HIPIncludePath-not-needed.patch"
"${FILESDIR}/${PN}-5.3.3-fix-tests.patch"
"${FILESDIR}/${PN}-5.3.3-fno-stack-protector.patch"
+ "${FILESDIR}/${PN}-5.3.3-remove-h-option.patch"
)
DESCRIPTION="Radeon Open Compute Code Object Manager"