summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-20 23:07:47 +0100
committerSam James <sam@gentoo.org>2022-04-20 23:08:58 +0100
commit8bb929497dbc0fcc69a6e6086c05cefd4d19bb3b (patch)
treeb0b2ce07cef5b805c1fddf61ac9d0c78a8456596 /dev-libs/quazip
parentprofiles/arch/s390: mask USE=subversion (diff)
downloadgentoo-8bb929497dbc0fcc69a6e6086c05cefd4d19bb3b.tar.gz
gentoo-8bb929497dbc0fcc69a6e6086c05cefd4d19bb3b.tar.bz2
gentoo-8bb929497dbc0fcc69a6e6086c05cefd4d19bb3b.zip
dev-libs/quazip: fix automagic Qt 5/6 usage; fix subslot
- We can't rely on autodetection of Qt version because this would be an automagic dependency. - SONAME changed from 1.0 -> 1.3, so change subslot Bug: https://bugs.gentoo.org/839264 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/quazip')
-rw-r--r--dev-libs/quazip/quazip-1.3-r1.ebuild (renamed from dev-libs/quazip/quazip-1.3.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-libs/quazip/quazip-1.3.ebuild b/dev-libs/quazip/quazip-1.3-r1.ebuild
index 43b0ab41e9e2..896e591fba00 100644
--- a/dev-libs/quazip/quazip-1.3.ebuild
+++ b/dev-libs/quazip/quazip-1.3-r1.ebuild
@@ -10,7 +10,8 @@ HOMEPAGE="https://stachenov.github.io/quazip/"
SRC_URI="https://github.com/stachenov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/1"
+# SONAME of libquazip1-qt5.so, check QUAZIP_LIB_SOVERSION in CMakeLists.txt
+SLOT="0/1.3"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
@@ -34,6 +35,7 @@ PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
src_configure() {
local mycmakeargs=(
+ -DQUAZIP_QT_MAJOR_VERSION=5
-DBUILD_TESTING=$(usex test)
)