summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Fan <alexfanqi@yahoo.com>2021-11-09 12:07:47 +1100
committerMichael Orlitzky <mjo@gentoo.org>2021-11-08 22:37:10 -0500
commit444b2094dad9c3f4b5eb82592997534eb2e472ed (patch)
tree3d0b220ca35488937ceee6f02d16cc28ae2d01bb /dev-libs/ntl
parentdev-java/openjdk-bin: drop 8.292_p10, 11.0.11_p9-r1 (diff)
downloadgentoo-444b2094dad9c3f4b5eb82592997534eb2e472ed.tar.gz
gentoo-444b2094dad9c3f4b5eb82592997534eb2e472ed.tar.bz2
gentoo-444b2094dad9c3f4b5eb82592997534eb2e472ed.zip
dev-libs/ntl: add 11.4.4-r1
bump to EAPI 8 update bundled config.guess and config.sub automatically. Closes: https://bugs.gentoo.org/821061 Closes: https://github.com/gentoo/gentoo/pull/22822 Signed-off-by: Alex Fan <alexfanqi@yahoo.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-libs/ntl')
-rw-r--r--dev-libs/ntl/ntl-11.4.4-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/ntl/ntl-11.4.4-r1.ebuild b/dev-libs/ntl/ntl-11.4.4-r1.ebuild
new file mode 100644
index 000000000000..1b184a8a48c0
--- /dev/null
+++ b/dev-libs/ntl/ntl-11.4.4-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs gnuconfig
+
+DESCRIPTION="High-performance and portable C++ number theory library"
+HOMEPAGE="https://www.shoup.net/ntl/ https://github.com/libntl/ntl"
+SRC_URI="https://www.shoup.net/ntl/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/43"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="bindist doc static-libs threads cpu_flags_x86_avx2"
+
+BDEPEND="dev-lang/perl"
+DEPEND="dev-libs/gmp:0=
+ dev-libs/gf2x
+ threads? ( >=dev-libs/gf2x-1.2 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+REQUIRED_USE="bindist? ( !cpu_flags_x86_avx2 )"
+
+DOCS=( "${WORKDIR}/${P}"/README )
+
+src_unpack() {
+ default
+ gnuconfig_update "${S}/libtool-origin/"
+}
+
+src_configure() {
+ # Currently the build system can build a static library or both
+ # static and shared libraries, but not only shared libraries. The
+ # name NTL_GMP_LIP is *not* a typo.
+ perl DoConfig \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR="${EPREFIX}"/usr/$(get_libdir) \
+ CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ SHARED=on \
+ NTL_GMP_LIP=on \
+ NTL_GF2X_LIB=on \
+ NTL_THREADS=$(usex threads on off) \
+ NTL_ENABLE_AVX_FFT=$(usex cpu_flags_x86_avx2 on off) \
+ NATIVE=$(usex bindist off on) \
+ || die "DoConfig failed"
+
+ if use doc; then
+ DOCS+=( "${WORKDIR}/${P}"/doc/*.txt )
+ HTML_DOCS=( "${WORKDIR}/${P}"/doc/*.html "${WORKDIR}/${P}"/doc/*.gif )
+ fi
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ # bug #775884
+ find "${ED}" -name '*.la' -delete || die
+ rm "${ED}/usr/$(get_libdir)"/libntl.a || die
+ fi
+
+ rm -r "${ED}"/usr/share/doc/NTL || die
+}