summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-22 10:27:44 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-22 10:33:59 +0200
commit93fa016c35ea45398acbbc88d73687125af6cd45 (patch)
tree7098182b2f0de9006a08edfa65a5bdae7ba47bc3 /dev-libs/mongo-c-driver
parentperl-module.eclass: Add DEFAULT_UNSET where applicable (diff)
downloadgentoo-93fa016c35ea45398acbbc88d73687125af6cd45.tar.gz
gentoo-93fa016c35ea45398acbbc88d73687125af6cd45.tar.bz2
gentoo-93fa016c35ea45398acbbc88d73687125af6cd45.zip
dev-libs/mongo-c-driver: Work around "error: storage size of ‘ai_hints’ isn’t known" (bug #564334 by Marcin Mirosław).
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs/mongo-c-driver')
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-0.7.1-r1.ebuild5
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1-r1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1-r1.ebuild
index 4a4f4366d135..7226e95ee5d4 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1-r1.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=(python2_7)
-inherit multilib python-r1 toolchain-funcs
+inherit flag-o-matic multilib python-r1 toolchain-funcs
DESCRIPTION="C Driver for MongoDB"
HOMEPAGE="http://www.mongodb.org/ https://github.com/mongodb/mongo-c-driver"
@@ -35,6 +35,7 @@ src_prepare() {
}
src_compile() {
+ append-cflags -D_POSIX_C_SOURCE=200112L
emake
use doc && make -C docs/source/sphinx html
}
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild
index 17902af5511f..aaf844fa1fc1 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit base multilib python-any-r1 toolchain-funcs
+inherit base flag-o-matic multilib python-any-r1 toolchain-funcs
DESCRIPTION="C Driver for MongoDB"
HOMEPAGE="http://www.mongodb.org/ https://github.com/mongodb/mongo-c-driver"
@@ -34,6 +34,7 @@ src_unpack() {
}
src_compile() {
+ append-cflags -D_POSIX_C_SOURCE=200112L
tc-export CC
emake
use doc && make -C docs/source/sphinx html