summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-08-18 11:09:37 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-01 20:16:41 +0300
commitd5a61feec230257bc2a06c0ed02aa8a19deeb7fa (patch)
treeca6e063f73874dbd434ab6c65ee07248f8b1f6ce /dev-libs/modsecurity
parentmetadata/stabilization-groups: fix extension for python/glake8 (diff)
downloadgentoo-d5a61feec230257bc2a06c0ed02aa8a19deeb7fa.tar.gz
gentoo-d5a61feec230257bc2a06c0ed02aa8a19deeb7fa.tar.bz2
gentoo-d5a61feec230257bc2a06c0ed02aa8a19deeb7fa.zip
dev-libs/modsecurity: add 3.0.10
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs/modsecurity')
-rw-r--r--dev-libs/modsecurity/Manifest1
-rw-r--r--dev-libs/modsecurity/modsecurity-3.0.10.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/modsecurity/Manifest b/dev-libs/modsecurity/Manifest
index 2a0438072ef9..93850a1ab582 100644
--- a/dev-libs/modsecurity/Manifest
+++ b/dev-libs/modsecurity/Manifest
@@ -1,2 +1,3 @@
+DIST modsecurity-v3.0.10.tar.gz 3341295 BLAKE2B 9ae4d52ccc77eb7f6a50fb37b07d0c0022e7d4c93bc4c04e7c6cdfabc7b6f6a19a3f0ec1f0151eb1bbd98d9c55de774048bc7636f67e735169b8c628d71fc0fd SHA512 2f51c9bfd2e91d93ddb8c48671dca08f91682745ff6bab6b8153376207d77c40f9afdcab7fa04d2fe925a19343bbfc57e52f0b45b3a50b30de4c1949f5b77ed9
DIST modsecurity-v3.0.8.tar.gz 3336288 BLAKE2B de15124362f23c86a6dcee15dd847fcf703a378a57ebd4826a6304fed33b34f4791c7aa80abd42cbe5932063c1ca59f755345e3810dcbc296e2b6a758e0c580b SHA512 8113358548aea19a18de183922e979fd7ce9daad289c6894bda458176f17da63fb45160a2a86d97730c90191c881b232b1c9c6ab9209c3988b4390e49e086117
DIST modsecurity-v3.0.9.tar.gz 3337195 BLAKE2B 5de70546463b9cf167e8e3fd13c55b3856dbe4f23f94a8f83a65890a4e5ea990597a0bb00f4dc24a52a3eb36fe6fa80a8d4a857f86bff3db5808b0d0bdd82b03 SHA512 49790031a82a6cece9cf53a03480490c0bdfd56302ea2e55319a27abdadf1aee060d4a9f847b224a21533d24f6a9fc29b4ad3898b258e6a81934a03c00e32020
diff --git a/dev-libs/modsecurity/modsecurity-3.0.10.ebuild b/dev-libs/modsecurity/modsecurity-3.0.10.ebuild
new file mode 100644
index 000000000000..d450dca9e74d
--- /dev/null
+++ b/dev-libs/modsecurity/modsecurity-3.0.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Application firewall and intrusion detection"
+HOMEPAGE="https://github.com/SpiderLabs/ModSecurity"
+SRC_URI="https://github.com/SpiderLabs/ModSecurity/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc fuzzyhash geoip geoip2 json lmdb lua pcre2"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RDEPEND="dev-libs/libpcre:=
+ dev-libs/libxml2
+ net-misc/curl
+ fuzzyhash? ( app-crypt/ssdeep )
+ geoip? ( dev-libs/geoip )
+ geoip2? ( dev-libs/libmaxminddb )
+ json? ( dev-libs/yajl )
+ lmdb? ( dev-db/lmdb )
+ lua? ( ${LUA_DEPS} )
+ pcre2? ( dev-libs/libpcre2:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGES README.md modsecurity.conf-recommended unicode.mapping )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with fuzzyhash ssdeep)
+ $(use_with geoip )
+ $(use_with geoip2 maxmind)
+ $(use_with json yajl)
+ $(use_with lmdb)
+ $(use_with lua)
+ $(use_with pcre2)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd doc && doxygen doxygen.cfg || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/html
+ find "${ED}" -name '*.la' -delete || die
+}