summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/log4c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/log4c')
-rw-r--r--dev-libs/log4c/Manifest2
-rw-r--r--dev-libs/log4c/files/log4c-1.2.4-docdir.patch16
-rw-r--r--dev-libs/log4c/log4c-1.2.1.ebuild53
-rw-r--r--dev-libs/log4c/log4c-1.2.4.ebuild43
-rw-r--r--dev-libs/log4c/metadata.xml13
5 files changed, 127 insertions, 0 deletions
diff --git a/dev-libs/log4c/Manifest b/dev-libs/log4c/Manifest
new file mode 100644
index 000000000000..adbd5889181a
--- /dev/null
+++ b/dev-libs/log4c/Manifest
@@ -0,0 +1,2 @@
+DIST log4c-1.2.1.tar.gz 508139 SHA256 6ed40a41307c26d052667e1661437394ab00e29cd24ff2640b502ba8ab1e442b SHA512 d8a5122df4d0afcff4880464ca58afa0661db3c60242c8ed1d034acf217f642bf9db0b0601ee07e832195408a8fa2ee8be61e9ee3f6ab59834bb13ec8598d0fd WHIRLPOOL 3a5f7e682f5f1a0f2cb073a8c242c01b94df55791e361a8781177acf631adce30a86732718a8a618f72c2a34f096d1522ea9c208547123684327a6ac0b1a0d49
+DIST log4c-1.2.4.tar.gz 559789 SHA256 5991020192f52cc40fa852fbf6bbf5bd5db5d5d00aa9905c67f6f0eadeed48ea SHA512 bd66029183b545de6b46b803e128735c5b57af0ca7f8a0a1f1655565920778993362e3187ffbe9b4b5e85dbf4c700b7d1f1dd4d1a636bcb20bfdb71fc73d37ca WHIRLPOOL 30e90b35d1ccc9fd4687cd761fe99f9933cb17ad75c97c3c140c1e794b696aea0caf643dde434b7c90555c821eebb59b1874f8a61d4d26896bd71739816c5812
diff --git a/dev-libs/log4c/files/log4c-1.2.4-docdir.patch b/dev-libs/log4c/files/log4c-1.2.4-docdir.patch
new file mode 100644
index 000000000000..9bbb532da33b
--- /dev/null
+++ b/dev-libs/log4c/files/log4c-1.2.4-docdir.patch
@@ -0,0 +1,16 @@
+Respect the autotools docdir switch. Avoid installing a copy of the license.
+
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -1,10 +1,9 @@
+ man3dir = $(mandir)/man3
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
++docdir = @docdir@
+ docfiles = \
+ $(top_srcdir)/README \
+ $(top_srcdir)/AUTHORS \
+ $(top_srcdir)/NEWS \
+- $(top_srcdir)/COPYING \
+ $(top_srcdir)/ChangeLog
+
+ targets = doxygen.stamp
diff --git a/dev-libs/log4c/log4c-1.2.1.ebuild b/dev-libs/log4c/log4c-1.2.1.ebuild
new file mode 100644
index 000000000000..618e29d4418b
--- /dev/null
+++ b/dev-libs/log4c/log4c-1.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Log4c is a library of C for flexible logging to files, syslog and other destinations"
+HOMEPAGE="http://log4c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/log4c/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="debug doc examples +expat"
+
+RDEPEND="media-gfx/graphviz
+ expat? ( dev-libs/expat )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_configure() {
+ local myconf
+ myconf="${myconf} --disable-expattest"
+
+ econf \
+ $(use_enable doc doxygen) \
+ $(use_enable debug) \
+ $(use_enable expat) \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}
diff --git a/dev-libs/log4c/log4c-1.2.4.ebuild b/dev-libs/log4c/log4c-1.2.4.ebuild
new file mode 100644
index 000000000000..06a2fbfd484e
--- /dev/null
+++ b/dev-libs/log4c/log4c-1.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Log4c is a library of C for flexible logging to files, syslog and other destinations"
+HOMEPAGE="http://log4c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/log4c/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples +expat static-libs"
+
+RDEPEND="expat? ( dev-libs/expat )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}/${P}-docdir.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-expattest
+ $(use_enable debug)
+ $(use_enable doc)
+ )
+
+ use expat || myeconfargs+=( --without-expat )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}
diff --git a/dev-libs/log4c/metadata.xml b/dev-libs/log4c/metadata.xml
new file mode 100644
index 000000000000..8a00054aee53
--- /dev/null
+++ b/dev-libs/log4c/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Log4c is a library of C for flexible logging to files, syslog and other destinations. It is modeled after the Log for Java library (http://jakarta.apache.org/log4j/), staying as close to their API as is reasonable.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">log4c</remote-id>
+ </upstream>
+</pkgmetadata>