summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libspnav
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libspnav')
-rw-r--r--dev-libs/libspnav/Manifest1
-rw-r--r--dev-libs/libspnav/files/libspnav-0.2.2-custom-flags.patch75
-rw-r--r--dev-libs/libspnav/files/libspnav-0.2.2-makefile.patch27
-rw-r--r--dev-libs/libspnav/libspnav-0.2.2.ebuild48
-rw-r--r--dev-libs/libspnav/metadata.xml25
5 files changed, 176 insertions, 0 deletions
diff --git a/dev-libs/libspnav/Manifest b/dev-libs/libspnav/Manifest
new file mode 100644
index 000000000000..45d1633f88d2
--- /dev/null
+++ b/dev-libs/libspnav/Manifest
@@ -0,0 +1 @@
+DIST libspnav-0.2.2.tar.gz 11615 SHA256 fb72388770d7dcd85b56ac2a83948983f1afd7dbe271e18d507b975ac4bea14f SHA512 78b26e6fe4a98af579738743ac4bc2f1de5ccfa9316a103a58ebb935f281fba04b8c6c28c0d63abda15a52c0288e371231425a3a21b26c083a5de7ab101f1940 WHIRLPOOL 07c542aadbbf334f34ed9dd59e4484855859ac85705c3dfe5f5c37035a1bf1b1bcc2aafd09ea3ec92f8699a33b6d6ab3db5542c073c74563ab0d61c131597be4
diff --git a/dev-libs/libspnav/files/libspnav-0.2.2-custom-flags.patch b/dev-libs/libspnav/files/libspnav-0.2.2-custom-flags.patch
new file mode 100644
index 000000000000..cc96655bf469
--- /dev/null
+++ b/dev-libs/libspnav/files/libspnav-0.2.2-custom-flags.patch
@@ -0,0 +1,75 @@
+diff -Npur libspnav-0.2.2.orig/Makefile.in libspnav-0.2.2/Makefile.in
+--- libspnav-0.2.2.orig/Makefile.in 2012-01-31 22:34:01.448356249 +0100
++++ libspnav-0.2.2/Makefile.in 2012-01-31 22:39:20.229350669 +0100
+@@ -7,7 +7,8 @@ lib_so = $(soname).1
+
+ CC = gcc
+ AR = ar
+-CFLAGS = $(opt) $(dbg) -std=c89 -fpic -pedantic -Wall -fno-strict-aliasing -I.
++CFLAGS = $(opt) -fpic -I.
++LDFLAGS = $(ldopt) -shared -Wl,-soname,$(soname)
+
+ .PHONY: all
+ all: $(lib_a) $(lib_so)
+@@ -16,7 +17,7 @@ $(lib_a): $(obj)
+ $(AR) rcs $@ $(obj)
+
+ $(lib_so): $(obj)
+- $(CC) -shared -Wl,-soname,$(soname) -o $@ $(obj)
++ $(CC) $(LDFLAGS) -o $@ $(obj)
+
+ %.o: $(srcdir)/%.c
+ $(CC) $(CFLAGS) -c $< -o $@
+diff -Npur libspnav-0.2.2.orig/configure libspnav-0.2.2/configure
+--- libspnav-0.2.2.orig/configure 2012-01-31 22:34:01.448356249 +0100
++++ libspnav-0.2.2/configure 2012-01-31 22:34:39.703355615 +0100
+@@ -4,6 +4,7 @@ echo 'configuring spacenav library...'
+
+ PREFIX=/usr/local
+ OPT=yes
++LDOPT=yes
+ DBG=yes
+ X11=yes
+
+@@ -26,6 +27,11 @@ for arg; do
+ --disable-opt)
+ OPT=no;;
+
++ --enable-ldopt)
++ LDOPT=yes;;
++ --disable-ldopt)
++ LDOPT=no;;
++
+ --enable-debug)
+ DBG=yes;;
+ --disable-debug)
+@@ -44,6 +50,8 @@ for arg; do
+ echo ' --disable-x11: disable X11 communication mode'
+ echo ' --enable-opt: enable speed optimizations (default)'
+ echo ' --disable-opt: disable speed optimizations'
++ echo ' --enable-ldopt: enable link optimizations (default)'
++ echo ' --disable-ldopt: disable link optimizations'
+ echo ' --enable-debug: include debugging symbols (default)'
+ echo ' --disable-debug: do not include debugging symbols'
+ echo 'all invalid options are silently ignored'
+@@ -54,6 +62,7 @@ done
+
+ echo " prefix: $PREFIX"
+ echo " optimize for speed: $OPT"
++echo " optimize link: $LDOPT"
+ echo " include debugging symbols: $DBG"
+ echo " x11 communication method: $X11"
+ echo ""
+@@ -74,7 +83,11 @@ if [ "$DBG" = 'yes' ]; then
+ fi
+
+ if [ "$OPT" = 'yes' ]; then
+- echo 'opt = -O3' >>Makefile
++ echo "opt = ${CFLAGS:--O3}" >>Makefile
++fi
++
++if [ "$LDOPT" = 'yes' ]; then
++ echo "ldopt = ${LDFLAGS}" >>Makefile
+ fi
+
+ if [ "$X11" = 'yes' ]; then
diff --git a/dev-libs/libspnav/files/libspnav-0.2.2-makefile.patch b/dev-libs/libspnav/files/libspnav-0.2.2-makefile.patch
new file mode 100644
index 000000000000..f65300c5f58a
--- /dev/null
+++ b/dev-libs/libspnav/files/libspnav-0.2.2-makefile.patch
@@ -0,0 +1,27 @@
+diff -Npur libspnav-0.2.2.orig/Makefile.in libspnav-0.2.2/Makefile.in
+--- libspnav-0.2.2.orig/Makefile.in 2012-01-31 22:40:36.619349333 +0100
++++ libspnav-0.2.2/Makefile.in 2012-01-31 22:41:52.554347975 +0100
+@@ -11,7 +11,7 @@ CFLAGS = $(opt) -I.
+ LDFLAGS = $(ldopt) -shared -Wl,-soname,$(soname)
+
+ .PHONY: all
+-all: $(lib_a) $(lib_so)
++all: $(lib_so)
+
+ $(lib_a): $(obj)
+ $(AR) rcs $@ $(obj)
+@@ -31,10 +31,10 @@ distclean:
+ rm -f $(obj) $(lib_a) $(lib_so) Makefile
+
+ .PHONY: install
+-install: $(lib_a) $(lib_so)
+- cp $(lib_a) $(PREFIX)/$(libdir)/$(lib_a)
+- cp $(lib_so) $(PREFIX)/$(libdir)/$(lib_so)
+- for h in $(hdr); do cp -p $(srcdir)/$$h $(PREFIX)/include/; done
++install: $(lib_so)
++ mkdir -p $(DESTDIR)$(PREFIX)/$(libdir) $(DESTDIR)$(PREFIX)/include
++ cp $(lib_so) $(DESTDIR)$(PREFIX)/$(libdir)/$(lib_so)
++ for h in $(hdr); do cp -p $(srcdir)/$$h $(DESTDIR)$(PREFIX)/include/; done
+
+ .PHONY: uninstall
+ uninstall:
diff --git a/dev-libs/libspnav/libspnav-0.2.2.ebuild b/dev-libs/libspnav/libspnav-0.2.2.ebuild
new file mode 100644
index 000000000000..bb4bcaad5f66
--- /dev/null
+++ b/dev-libs/libspnav/libspnav-0.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib eutils toolchain-funcs
+
+MY_PN='spacenav'
+DESCRIPTION="The libspnav provides a replacement of the magellan library with cleaner and more orthogonal API"
+HOMEPAGE="http://spacenav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${MY_PN}/${MY_PN}%20library%20%28SDK%29/${PN}%20${PV}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="X"
+
+RDEPEND="app-misc/spacenavd[X?]"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-custom-flags.patch
+}
+
+src_configure() {
+ econf \
+ --enable-opt --enable-ldopt \
+ $(use_enable X x11)
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ # Use proper libdir
+ if [[ $(get_libdir) != lib ]]; then
+ mv "${D}"/usr/{lib,$(get_libdir)} || die
+ fi
+
+ # Create missing symlinks
+ local target=$(basename "${D}"/usr/$(get_libdir)/libspnav.so.*)
+ dosym ${target} /usr/$(get_libdir)/libspnav.so.0 || die
+ dosym ${target} /usr/$(get_libdir)/libspnav.so || die
+}
diff --git a/dev-libs/libspnav/metadata.xml b/dev-libs/libspnav/metadata.xml
new file mode 100644
index 000000000000..14da66cc7fac
--- /dev/null
+++ b/dev-libs/libspnav/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>anthoine.bourgeois@gmail.com</email>
+ <name>Anthoine Bourgeois</name>
+ </maintainer>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription>
+ The libspnav library is provided as a replacement of the magellan
+ library. It provides a cleaner, and more orthogonal interface. libspnav
+ supports both the original X11 protocol for communicating with the
+ driver, and the new alternative non-X protocol. Programs that choose to
+ use the X11 protocol, are automatically compatible with either the free
+ spacenavd driver or the official 3dxserv, as if they were using the
+ magellan SDK.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">spacenav</remote-id>
+ </upstream>
+</pkgmetadata>