summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libexplain
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libexplain')
-rw-r--r--dev-libs/libexplain/Manifest2
-rw-r--r--dev-libs/libexplain/files/libexplain-0.45-configure.patch23
-rw-r--r--dev-libs/libexplain/libexplain-1.3.ebuild52
-rw-r--r--dev-libs/libexplain/libexplain-1.4.ebuild51
-rw-r--r--dev-libs/libexplain/metadata.xml5
5 files changed, 133 insertions, 0 deletions
diff --git a/dev-libs/libexplain/Manifest b/dev-libs/libexplain/Manifest
new file mode 100644
index 000000000000..844d82d604c3
--- /dev/null
+++ b/dev-libs/libexplain/Manifest
@@ -0,0 +1,2 @@
+DIST libexplain-1.3.tar.gz 4742321 SHA256 18b76bd95f9476edc627ae3a3414e364e14c7f461df0c7925919fc9bddce643a SHA512 2af805f8f51912ad2d74326df3b6e7f5423a9af68a930c8f765eb839d2348a4c8e176c81eb6c953795764d08faff97d71132e68fcfcf09242575b0eab7b53120 WHIRLPOOL 83258f5432b0eb374c808e8696c99d8b6798dc87887f18582d57d23668d976e81c2e9d0212852153b00a59ca71f3f63b8ddd110759a3e34a79868d97a98aa20a
+DIST libexplain-1.4.tar.gz 4770006 SHA256 28863b65eccc74934e237cac41364cb3c1802c36c9e2318ed0417460fee83f80 SHA512 c236732f57d0688fed173c27474a00a39c9ac6d5dfbd22f3b68b5d0fff7a70fb130bcedbeb174767f4fd2c012148025e92635cc8df2b958774a3cfba58e6ff2c WHIRLPOOL ce3131c68d57c3d867960eaf2451d5aed152276c85e0182fee70b6499ebbee29ae0fea6d1a84aaefa927c9b983677953003b1a253e54ab3fc516d2b70dc3a3c1
diff --git a/dev-libs/libexplain/files/libexplain-0.45-configure.patch b/dev-libs/libexplain/files/libexplain-0.45-configure.patch
new file mode 100644
index 000000000000..e82d05da534f
--- /dev/null
+++ b/dev-libs/libexplain/files/libexplain-0.45-configure.patch
@@ -0,0 +1,23 @@
+--- libexplain-0.45.D001.orig/configure.ac
++++ libexplain-0.45.D001/configure.ac
+@@ -26,6 +26,10 @@
+ AC_PROG_RANLIB
+ AC_PROG_YACC
+
++LT_INIT
++top_builddir=`pwd`
++AC_SUBST(top_builddir)
++
+ case "$YACC" in
+ *bison*)
+ ;;
+--- libexplain-0.45.D001.orig/Makefile.in
++++ libexplain-0.45.D001/Makefile.in
+@@ -35,6 +35,7 @@
+ #
+ # directory containing the source
+ #
++top_builddir = @top_builddir@
+ srcdir = @srcdir@
+ VPATH = @srcdir@
+
diff --git a/dev-libs/libexplain/libexplain-1.3.ebuild b/dev-libs/libexplain/libexplain-1.3.ebuild
new file mode 100644
index 000000000000..3dbe8fd2aab3
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="doc static-libs"
+
+RDEPEND="
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11
+ sys-process/lsof"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.35
+ app-text/ghostscript-gpl
+ sys-apps/groff
+"
+
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}" || die
+
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile all-doc
+}
diff --git a/dev-libs/libexplain/libexplain-1.4.ebuild b/dev-libs/libexplain/libexplain-1.4.ebuild
new file mode 100644
index 000000000000..3fe85c83ee1a
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="static-libs"
+
+RDEPEND="
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11
+ sys-process/lsof"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.35
+ app-text/ghostscript-gpl
+ sys-apps/groff
+"
+# Test fails with:
+# This is not a bug, but it does indicate where libexplain's ioctl support
+# could be improved.
+RESTRICT="test"
+
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}" || die
+
+ autotools-utils_src_prepare
+}
diff --git a/dev-libs/libexplain/metadata.xml b/dev-libs/libexplain/metadata.xml
new file mode 100644
index 000000000000..f23b9cae1593
--- /dev/null
+++ b/dev-libs/libexplain/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>