summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-23 18:11:06 +0000
committerSam James <sam@gentoo.org>2024-03-23 18:11:06 +0000
commit70ec3ac4c1b52d29c86004c74ddabbefa919866a (patch)
tree353cd4f58cd6d80aa9a9dbb5b6149cabbe1ebd3c /dev-libs/libdnet
parentprofiles/arch/powerpc/ppc64: mask dev-python/QtPy[webengine,test] (diff)
downloadgentoo-70ec3ac4c1b52d29c86004c74ddabbefa919866a.tar.gz
gentoo-70ec3ac4c1b52d29c86004c74ddabbefa919866a.tar.bz2
gentoo-70ec3ac4c1b52d29c86004c74ddabbefa919866a.zip
dev-libs/libdnet: fix tests
XFAIL 2 known-bad tests, using Debian's rationale (they also only fail in our sandboxes IIRC). Thanks to matoro for the hint. Closes: https://bugs.gentoo.org/778797 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/libdnet-1.16.4.ebuild8
-rw-r--r--dev-libs/libdnet/libdnet-1.17.0.ebuild11
-rw-r--r--dev-libs/libdnet/libdnet-1.18.0.ebuild9
3 files changed, 22 insertions, 6 deletions
diff --git a/dev-libs/libdnet/libdnet-1.16.4.ebuild b/dev-libs/libdnet/libdnet-1.16.4.ebuild
index 63ed423fc1db..f711dff63e94 100644
--- a/dev-libs/libdnet/libdnet-1.16.4.ebuild
+++ b/dev-libs/libdnet/libdnet-1.16.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,6 +70,12 @@ src_compile() {
fi
}
+src_test() {
+ # https://bugs.gentoo.org/778797#c4
+ # check_ip needs privileges and check_fw can't work on Linux
+ emake check XFAIL_TESTS="check_fw check_ip"
+}
+
src_install() {
default
diff --git a/dev-libs/libdnet/libdnet-1.17.0.ebuild b/dev-libs/libdnet/libdnet-1.17.0.ebuild
index 6375fca7a56c..fd47d46e0186 100644
--- a/dev-libs/libdnet/libdnet-1.17.0.ebuild
+++ b/dev-libs/libdnet/libdnet-1.17.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,8 +17,7 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="python test"
-# Tests fail in sandbox
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -75,6 +74,12 @@ src_compile() {
fi
}
+src_test() {
+ # https://bugs.gentoo.org/778797#c4
+ # check_ip needs privileges and check_fw can't work on Linux
+ emake check XFAIL_TESTS="check_fw check_ip"
+}
+
src_install() {
default
diff --git a/dev-libs/libdnet/libdnet-1.18.0.ebuild b/dev-libs/libdnet/libdnet-1.18.0.ebuild
index acb3b2536aa4..fd47d46e0186 100644
--- a/dev-libs/libdnet/libdnet-1.18.0.ebuild
+++ b/dev-libs/libdnet/libdnet-1.18.0.ebuild
@@ -17,8 +17,7 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="python test"
-# Tests fail in sandbox
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -75,6 +74,12 @@ src_compile() {
fi
}
+src_test() {
+ # https://bugs.gentoo.org/778797#c4
+ # check_ip needs privileges and check_fw can't work on Linux
+ emake check XFAIL_TESTS="check_fw check_ip"
+}
+
src_install() {
default